[SOLVED] eLicenser crashes when I put my Activation Code

Dear Sirs,

I’ve just installed macOS Sierra and reinstalled Dorico. When I open the program, a notification appears: “No license was found, click Enter your Activation Code.”

When I open the Soft e-Installer and enter my Activation Code, the Soft e-Installer crashes.

What to do?

Could you please try to reinstall just the eLicenser Control Center. You can download the latest version from this page:
http://www.steinberg.net/en/company/technologies/elicenser.html

Then try again with entering the activation code and see what that does.

I did this, the crash still exists.

I uninstalled and reinstalled the whole bloody staff: Dorico and e-Licenser. The problem is still the same: the e-Licenser requires Activation Code, and when I am inputting it, at the end crashes the program.
Please help!

Can you run eLicenser Control Center directly? What version does it show in the title bar? It should be 6.10.2.18201 or later.

If you enter the Activation Code directly into eLCC without first running Dorico, does that help at all?

The version is 6.10.2.18201.
If I enter the Activation Code without opening Dorico, the crash still exists.

Can you see if there are any crash reports from eLCC in your ~/Library/Logs/DiagnosticReports folder? Note the tilde ~ in the path name there, which is shorthand for your user account’s home folder — crash logs go in user-level folders, not system-level ones. If you can find some crash reports from eLCC, please zip them up and attach them here and I’ll ask the eLicenser team to take a look.

Yes, I’ve found it. I send it here. Thank you very much.
License Control Center_2016-10-31-102824_Gyongyosi-Mac-Pro.crash.zip (16.4 KB)

I have the exact same problem. After entering the code I receive a message “No license was found, Enter your Activation Code.” eLicenser crashes immediately. Latest version of eLicenser installed.

Hi,

A few days ago I was in contact with a customer who had the same problem.

I was able to fix it by using the eLc Helper to overwrite the Soft-eLicenser.

  • Close all programs.
  • Download and install the eLc helper:

http://support.steinberg.de/elc/mac/elc-installation-helper.zip

Try to activate again.

If you still experience crashes when trying to activate, please delete the file eLicenserCore.framework, which can be found under Library -> Application Support -> eLicenser -> Tools

Try to activate again.


Cheers,
Jochen

I tried all this. Sorry, but it doesn’t works. The crash still exists.

Hi, thanks for trying to help, but step 1 didn’t work, and step 2 I couldn’t execute. After looking in Library -> Application Support there was no eLicenser folder in it. What should I do? Very frustrating!

I think for eLicenser problems I would recommend contacting support. If you go to your MySteinberg account you will find a contact form to get in touch with our support team, who are more experienced than us in the Dorico team at handling eLicenser problems, and they will very probably be able to help you more quickly than we can. I’m very sorry that you have had this frustrating introduction to your use of Dorico.

I’ve just wrote an e-mail to Steinberg support. Thank you, Daniel. I hope they can help us soon.

Hi Rameau64,

would you care to share the support response after you get it? And what is your OS, please?

I’m having the same issues, but it’s not related to Dorico, cause I don’t own it. I just install Sierra on my Macbook Pro and that’s it: crashes after entering an activation code. As I downloaded the eLc helper, I could note that when asked for the OSX, Sierra wasn’t listed. So on my side I’m almost sure that it is an OS incompatibility. Ah! I could not find the eLicenser folder.

Good Luck to us!

Hi monkzelaya,

of course I will post here the answer of support team. I didn’t get their answer yet.
Yes, my operation system is the same: macOS Sierra, so the eLicenser incompatibility could exist, but would be very strange because Dorico is listed as compatible with Sierra.

Good luck!

Please be sure your are not searching in the User Library.

I think without the eLicenser folder in the System Library, the eLicenser Control Center would not be able to run.

So please follow this path:

“Name of your Hard Drive aka Macintosh HD” -> Library -> Application Support -> eLicenser -> Tools

I was indeed looking in the user library instead of the system library. Now I found the file, deleted it and… nothing has changed. I contacted Support on Monday, still no reply.

@ itaiso76,

Please check your mail inbox.

Cheers,
Jochen

Just for be sure I made the whole process one more time with my System Library. I deleted the eLicenser core.framework and tried the completion of the Activation Code one more time - but the crash appears loyally.

I get an e-mail from the Steinberg Support: “We are looking for the reason of the problem. We will notify you.”