[SOLVED] Emvoice no longer receiving MIDI data

I have been using Emvoice for some time to synthesize MIDI vocals. Until this morning I have had no trouble selecting Emvoice as a VST and assigning it to one of my singers (or assigning multiple instances to multiple singers.

Suddenly this morning, on one particular file, Emvoice does not “read” the MIDI information and register it in its VST screen as notes to which I can add words.

Emvoice has no problem playing other files on which I have used the VST. Normally Emvoice is silent while “reading” and loading the MIDI info into its VST, but on this file there is a shadow sound (like a bassoon or baritone singer) audible.

Here is a diagnostic report. I can email the file to @dspreadbury or another team member if something seems to have corrupted it.
Dorico Diagnostics.zip (2.5 MB)

In the audio engine logs I see entries like e.g.

2023-01-31 10:29:36 : loadInstrument Emvoice One (id 2543)…
2023-01-31 10:29:37 : 05. Emvoice One - MIDI Input: id => 2547 StreamId => 5
2023-01-31 10:29:37 : Output: id => 2546
2023-01-31 10:29:37 : => Emvoice One loaded

So it loads and also seems to get connected to MIDI.
But then later I see other instances with just

2023-01-31 10:29:41 : loadInstrument (id 2885)…
2023-01-31 10:29:41 : => Emvoice One loaded
2023-01-31 10:29:41 : addReturnChannel 2890

Here obviously no MIDI connection was established for reasons I don’t know.
Are you maybe missing some expression maps or so?

No expression special expression map was needed in the past. The default EM has been workable. (In fact there is no connection between Dorico dynamics and Emvoice; that has to be handled manually or exported into Cubase when needed).

Here for comparison is a Diagnosticc from a project in which Emvoice still works.
Dorico Diagnostics.zip (2.5 MB)

Just solved this. Apparently something had corrupted the original file. When I exported XML and opened that as a new project, the Emvoice player can “read” the vocal MIDI>

Thanks, @Ulf for looking at this.

1 Like