SOLVED ! (extremely) Inconsistent Midi timing Between plugin

this not the first time that i encounter this kind of behaviour, but first time that i take time to report it >

i’ve been trying GA se as a midi pattern player, the set up is extremely simple :
GA playing midi files / pattern ( 1 to 3 bars ) only one pitch ( rhythmic part )
i have a hi hat sample in GA to check in audio that it is playing OK

than another plugin ( retrologue ) receiving midi from GA midi out ( midi in from GA, midi monitor ON )

Retrologue is playing, but the timing is so messed up you can’t even recognise the original rhythm
( i mean it is not just a tiny groove or delay problem )

i first tried that in my big work template.
than make an empty project ( only 2 tracks ), same problem.

i tried two ways :
transport = stop
playing GA, retrologue monitoring on


record a midi part on GA track ( just notes triggering the patterns )
Retrologue monitoring on

both ways are total chaos… unusable.

i have to say i have short and fast notes ( think trap hi hat kind of part / in fact more flamenco guitar strum rhythm type of pattern )
but nothing that a human hand can’t do, i could play this kind of patterns on a pad.

Other test >>
if i drag the pattern from GA to the retrologue track ( mini monitor = off ), it plays fine

it seems like midi between two vst is badly buffered / got no timing reference ?

if it is not a bug, how can we overcome this behaviour…
this an absolute nonsense to me and a total workflow breaker on the project i’m writing music for actually…

Settings :
i use a rme fireface
64bits processing
multi process active
asio guard = low
audio priority = boost
steinberg power scheme = on
disk preload 4 sec
adjust for record latency = on
record shift = 0

system timestamp for windows midi input = off
use device direct music = off

Lower your device driver buffer on the RME in Cubase

How are you routing the MIDI from one to the other exactly?

******* I have :

  1. Groove Agent running a Techno MIDI loop here output the midi to Retrologe (Both in the Rack Instruments section).
  2. It is in TIME here, synced fine

hey thanks for the quick answer !

( btw : i used instrument track for the test )

I run my RME Buffer @ 1024, lowering the buffers @ 256 or below get it working properly in my very simple 2 tracks test project and in my big work template.

thank you very much !

i’ll edit the thread as SOLVED

That MIDI buffer is tied to the AUDIO buffer, don’t let anyone tell you any different as you have just seen.
Im not FOS here, it is a real thing. I do ALL midi at lowest I can, then dump to audio, THEN raise the buffer up for mixing