[SOLVED] Focusrite Scarlett 2i2


I started tinkering with iPad recording with Harmonicdog Multitrack. It supported my Focusrite 2i2 with the Camera Connection Kit and a powered USB hub. However it did not support the MIDI clock which I wanted to use with DrumPerfect.

I purchased Cubasis and it worked beautifully with DrumPerfect. And I was very impressed with the design of the software. I did have some problems with undo working properly but overall I really enjoyed using it. I’d go so far as to say I was excited. It seemed well worth the price.

With the Camera Connection Kit and a powered USB hub it seems to see that my 2i2 provided two mono interfaces or a single stereo–the mono channels 1 & 2 and and the stereo channel 1+2 were selectable. However no sound could be heard or recorded (flat lined). So I “reported a problem” and was offered a refund which I accepted.

Then I downloaded Auria and, given many positive reviews, was surprised to find it extremely difficult to use. Obviously some love it and I can’t argue with their taste. Then I tried to get a refund and was rejected which pissed me off.

Can anyone help me get the Scarlett 2i2 working? I would happily purchase Cubasis if I can solve this problem. Does someone understand why it won’t work or why it “sees” it but cannot “hear” it?

What surprised me, and this may seem harsh, is that Steinberg seems to support what I think of as lesser products. USB mics rather than decent recording interfaces. Also, I thought the Scarletts support the Core Audio interface which would give them a chance of working provided that interface is well-implemented.

Thanks for reading.


I got around to reading the post about answering “yes” to the “can Cubasis use your microphone?” Corrected the problem by using Settings->Privacy->Microphone>Cubasis->Yes as described in that post.

I believe Auria has the same issue.