Solved: FX modulator sync problem

Hi there,

I have a problem with FX Modulator in C12.0.40, W10 22H2, RME Fireface UC last driver.

Phase sync button works perfect in the first part of my project and later on it doesn’t sync right. Time is set to 1/1, but it starts from second 1/4 note of every bar. Thing is that i copied that first event with FX Modulator bypass automation and used it later in the project. Maybe something has gone wrong with automation when i copied that event?

I even tried removing the plugin from that channel and inserting a new one and automating it again, but same problem happens. Now i’m thinking it has to do something with signature and tempo changes during the project. (To be clear, all those problematic places are in 4/4 signature).

Please help.

I’ll keep updating the post if anyone else has the same problem.

I tried to open a new project and replicate the problem (tempo and signature changes included) and it works fine.
Something must be the problem with that specific project. Btw that one was done in C11, and now i work on it in C12. FX Modulator was added in C12 of course.

I think i may have found a culprit of the bug. When i moved and copied that event in the part of the project where the signature is unchanged, everything works fine, but when i do that in part where there was a short change to 3/4 and then back to 4/4, that happens, and it losses sync exactly for that 1/4 note somehow.
I hope i helped to pin down the problem.

In most plugins, 1/1 could mean 4 quarter notes. If you have a 3/4 bar, there could be a problem like that. You will have to somehow work around using automation in such cases.

I don’t know if i was clear, but the problem is that i got back to 4/4 after that 3/4 change. It was a short change of signature so my bars can match the shot change in video track and i got back to 4/4 before FX modulator kicks in again, so it somehow forgot to get back in sync with 4/4 signature.

FXModulator does not use VST3 signature changes.
If you have a 4 bars passage as follow;
1 2 3 4 1 2 3 4 1 2 3 1 2 3 4
The FX modulator at 1/1 will start at,, then, because the 3rd bar is only 3 beats long, 1/1 in the plugin mean 4 beats, not 1 bar as it looks.

1 Like

Correct me if i’m wrong, but does mean that FX modulator only counts the number of bars set in it’s own UI and does not mind the changes in signature to reset it’s sync and starts counting again from the point where signature was changed?

It just divides the position where the host is started by 4 beats. E.g. if the start position was where the 2nd bar is 3/4, the position is 4 + 3 + 2 = 9 beats from the top, 9 / 4 = 2 bars and 1 beat, then the plugin starts to sync from 1/4 on the gui, i.e. 2nd beat.

It’s far from ideal as you have to copy these patterns forever, but you can work around like this;


By enabling the “MIDI” switch and setting it to 1 Cycle, a MIDI note starts the FXModulator’s cycle. Place these notes on every bar including the 3/4 and following then you can get the desired result.


I was just replicating the problem on a small scale in a new project and realized too that midi could work, but thank you for pointing that out!
Yes, it is far from ideal and it makes everything a bit more crowded with tracks, but it works. Thank you again, i think i can check your reply as solution. :slight_smile:

1 Like

Actually if you automate “MIDI” ON/OFF and just trigger it once at the 4/4 next to the 3/4, it could be a lot simpler but I’ve found a bug around it, once you automate “MIDI”, it loses ability to receive MIDI notes. I reported it but you’ll have to copy the events all the way for now.


I didn’t think that way (which is much easier), but just copied the events. It works like a charm, so problem solved. :man_shrugging:t2: Cheers!