(Solved)Halion Sonic Librarys

I’m still waiting for Steinberg Tech to reply back…but in the meantime…maybe someone can help out.

I have searched relentlessly, and have followed each of the threads directions but have found no resolution.

I have Cubase 9 Pro build 209 64bit. If my signature is out of date, as I think it is, I will update it shortly.

Here’s what comes up each time I open Cubase.

Halion Sonic SE Missing content
I have tried everything…for 5 days straight, including doing a complete fresh install of C9.

I cannot find or get rid of this content:
HALion Sonic
TR Kits 01
Grand Piano 01
Electric Guitar 01
Electric Guitar Add 01
Add 02
Acoustic Guitar 02
Add 02
Add 03
Blues Kit 01
Brush Add On 01
Cymbals HiHats 01
Dry Kit 01
Electric Kit 01
Funk Kit 01
Fusion Kit 01
Hard Rock Kit 01
Jazz Brush Kit 01
Latin Percussion 01
Metal Kit 01

I don t know if the … means there s more to the list or not.

I have uninstalled and reinstalled programs and content but the issue still persists.

Hi there

I once had a problem with a file not being found for halion sonic and eventually the solution was to do a “maintainence” update on my elicencer, may not solve anything but worth a try.

Best Regards


Yes, I did that also, but nothing seems to work.

I cannot even find if those missing items belong to which program.

I have deleted them and put them back. I have collected all VST Sounds and put them everywhere I could find that they belonged.

It’s driving me nuts…but everything else works fine.

Cubase used to load up in seconds…now it stalls on “content” for a minute or two, and up pops the dialog box.

Hi there

Yes that happened to me as well, a couple of years back, cant remeber the solution, have you tried running C9 in administrator mode, or if it is already, then not in admin mode, in the meantime i will try research my braincells to remember, what i did, the “getting stuck on content” bit is what I remember.

Best Regards


Yes, I’ve run in admin mode and not in admin mode.

Baffling me but I cannot let it go. When I get the dialog box that says they are missing or the trial license has expired, I delete them, but then more keep coming up. The dot dot dot at the end of the list means it must go one for pages.

I also ran my laptop C9 Pro, same build, and it loads like lightning. So I put the exact files in the assigned places.

I’m still in the same place.

The is chaos…and I’m the sort who lives for resolution. It’s getting to me.

I do appreciate your looking into it.

My last resort was to delete every VST Sound folder I could find. I then uninstalled C9 again.

I had an already downloaded zip of C9. I installed that. If it said I could reinstall any component, I took that option.

I did not let it install the update of 9.0.20.

Bottom line is all is well again.

Lesson to be learned?

I wish I knew, but it would be advantageous to have the option to reinstall these libraries in an easier fashion.

Thanks to those that helped!

I had a similar problem. I’ve never used Halion SE 2 and was trying it out last week and could not see any library files or patches either.
They were in the C:\Users[user name]\AppData\Roaming\Steinberg\Content\HALion\VST Sound directory but could not be found from the Cubase Halion app.

After hours of trying to figure it out I was about to give up on it and went to the Steinberg website and found there was a newer SE 3 version.

I downloaded and installed SE3 and was able to see the patches. What a PITA! (;