[Solved] Hiding empty staves in grand staff instruments-Chords collision (bug...?)

I know hiding staves have been discussed here a couple of times, but after a long discussion in the Dorico fb-group one new thing came up I haven’t seen before.
My original question was why hiding empty staves on grand staff instruments didn’t work. (E.g. piano, marimba etc.)
After changing Position of chord symbols of grand staff instruments in the chords section of Engraving options to Above top staff it works as expected. I guess this must be sort of a bug, or is it an expected behavior?

It’s the designed behaviour. You can’t hide one staff of the piano when you have asked Dorico to show the chord symbols between the staves.

Wow, that took some time for me but now I got it! :slight_smile:. I’ve searched the forum and the online manual but couldn’t find anything about this, maybe that’s one reason. (Another might be the tropical heat outside here in Sweden that makes my brain a bit slow going… :wink: )

So that means when you set the chords to show up between the staves on grand staff instruments you you cannot hide any unused staves unless you select Hide for all instruments in Setup -> Chord symbols?

Yes: if the piano is set to show chord symbols in Setup mode, and you’ve set them to show between the staves in Engraving Options, then setting the layout option to hide one staff of a piano will have on effect.

Oki, great, thanks Daniel! I just wanted to make sure since I couldn’t find this in the manual.

Oh, and I’m longing soooo for the coming update! Then I can say goodbye to Avid! :nerd_face: (a bit sad though, since I got on the Sibelius train on version 2. But since the shut down of the London office the spirit is gone…)

The spirit’s not gone at all – it’s simply moved a few miles down the road. And we are blessed to have been given the chance to put that spirit to work on a brand new and much better application. The update is coming very soon – not much longer to wait now.

Hooray! :slight_smile:

  • D.D.

The spirit’s not gone at all – it’s simply moved a few miles down the road.

Yes, that’s exactly what I meant. But I should of course have been a bit more clear. :ugeek:
Here is a clarification:
The spirit of the Avid software and team is GONE!

Dorico is the future when it comes to music notation. And when swing playback is possible I won’t start any new score in Sibelius anymore. And what I’ve read here on the forum this should be pretty soon… :slight_smile:

I’m not sure if this is the same problem. I set the chord symbols on engraving rules to be shown above:


I posted this on the Facebook group, just in case you want to check any other eventual answers: https://www.facebook.com/groups/dorico/permalink/2222075841403489/

In case it helps I attach an edited version of the file
Issues hidding staves.dorico.zip (846 KB)

Did you import this via musicxml? If so, select and delete the bass clef at the start of the first system.

That’s it! Yes, it was an imported musicxml file… Then I know it for the next 10 files I have to import

That problem with explicit clefs is a real one, as everyone trying to import xml’s runs into it… Maybe a new topic for a “Tip” video? :wink: