[Solved] How to get playback working

It seems to me that the Dorico team have been under unbearable pressure to get something out to the public - and what we have is promising, but not strictly usable except perhaps for simple projects. However, having long been of the opinion that Sibelius was one of the best computer programs I have ever used, I have total faith in the development team, and look forward to Dorico becoming the only scoring program worth having.

Meanwhile, could someone please advise me on how to get sound. I have tried the suggestions I’ve found on the various topics on the forum, and none have worked, not even the simple piano piece which seems to have been successful in other cases. On starting a piece, all voices load into Halion: the Activity Monitor indicates the audio engine is running, but the VU monitors in the Halion window remain stubbornly inactive. The green line remains static, although I’m a bit confused as to whether it’s supposed to move at this stage or not…

By the way, I have checked that the mute button is off, although I am quite capable of missing something equally obvious.

Configuration: iMac, 8Mb memory, OS 10.11.6
VSTAudioEngine_64 folder attached, as requested.
VSTAudioEngine.zip (238 KB)

I’m sure Ulf or somebody else who knows how to read those log files will be along shortly, but in the meantime, can you tell me which audio device is chosen as the output device in Edit > Device Setup?

Hi John,

looking at your attached data, indeed, the audio engine doesn’t recognize any audio device, not even the built-in sound chip, so accordingly it doesn’t know where to play out to and you will not hear anything.
So I assume that under Edit > Device Setup actually nothing is listed as output device, right?

And if you start the utility app /Applications/Utilities/Audio MIDI Setup , what does get listed in there as output device? If you are unsure, maybe you could make a screenshot and post it here.

Cheers,
Ulf

Ulf / Daniel

Thanks for getting back to me so quickly.
Device Setup has Built-in Audio as ASIO driver - there is no alternative available.
Midi Setup has Built-in Output.

I attach screen shots in case these tell you more than I’ve already said. I have no problem with Sibelius playback, and I have even persuaded Sibelius to play using Vienna Instruments (but only just, and not very satisfactorily).
DeviceSetUp.tif (48 KB)
DeviceSetUp.tif (48 KB)
DeviceSetUp.tif (48 KB)

Sorry - I got 1 pic wrong: here’s the midi setup…
MidiSetup.tif (155 KB)

Hi John,

thanks for the screenshots. Could you please try setting the sampling rate from 11025Hz to 44.1kHz and see if that might help (though normally it shouldn’t matter…)
If you still don’t get sound out, please quit Dorico, start new, create a new empty project, add some arbitrary notes, save the project and post here.
Additionally, please post the log files from your temp folder. Open a console window and type

open $TMPDIR/VSTAudioEngine

This will open a new Finder window where you can see several log files. Please zip them up and also post here.

Thanks
Ulf

tx4.dorico.zip (197 KB)
AudioEngineLogs.zip (12.3 KB)

Ulf

Changed sampling rate to 44100: still no sound, but the green line (and the time in the transport window) now moves, which didn’t happen before. However, the sampling rate defaults to 11025 every time I restart Dorico - even setting it in Preferences doesn’t keep the 44100 setting.

As instructed, I closed Dorico, then reopened it and started a new project (simple piano). File attached.

I typed your instruction into Terminal and I attach the log files. If you want the console log for this morning (and a bit of yesterday), please say: I’ve saved it to a text file just in case.

John

Thanks again for the files, John.

From the logs and the project file, I can clearly see that no sound is coming out with you, because simply your Built-in Audio device is not recognized by the audio engine, thus it plays out to void.

But to be honest, we have no clue at the moment, as to why on your machine the audio device won’t get recognized.
Well, the weird thing is, it partially gets recognized, because it appears in Dorico in the Device Setup dialog, and the list there gets filled up with information by the audio engine, so somehow it does get recognized, but not when actually connecting to it.

Could you do one more thing, please. In Dorico’s Device Setup dialog, click on the Control Panel button, a new window shall pop up. Would you please post another screenshot?

Thanks again

Ulf

Screenshot attached.

I sympathise with your dilemma. Perhaps I should try re-installing from the CDs?

John

Sorry, but you have just the Device Setup dialog open. If in there you click on the button that says “Device Control Panel…” another little window should pop up, that is what I want to see. If nothing is happening there, maybe that window opens behind the Dorico project window, so please try and minimize or move it out of the way.

Ulf

When I click Device Control Panel, the focus shifts to the Halion SE2 window. No new windows appear, and nothing is hiding behind the other windows. If I minimise both the Dorico window and Halion window, clicking the Device Control Panel produces no result.

John

Thanks John,

that’s interesting to hear and might give us a clue of where to look further.

I’ve logged this issue now in our bug base [AD-255]. We will continue investigating and come up with a solution, though I can’t promise when this will be. Hope you can wait a little.

Thanks for your patience
Ulf

Ulf
Thanks for your efforts so far. Of course there’s no panic: it will take time to get to know all of Dorico’s features (especially without a full manual), and I will be continuing with Sibelius until Dorico can match it.
John

Hi John,
in a brute force way I now managed to get Dorico into the same kind of state that you experience. At least here I can get it out of that state in a pretty simple way. So I’m asking you to do the same:
Open a Terminal window and type

open ~/Library/Preferences/VSTAudioEngine

A new Finder window will open and show you the content of that location. You will see a bunch of XML files and some subfolders. Please delete all of of those files and subfolders and then start Dorico again. Go to Edit > Device Setup, does Built-in Audio get listed as ASIO Driver? What happens if you click on Device Control Panel, does now the CoreAudio Device Settings dialog pop up? If so, then that is already the first step to success.

If indeed the CoreAudio Device Settings dialog shows up, then make sure that at the Output Configuration the ‘Built-in Output’ is ticked. Then close that dialog and create a simple Piano project and check if sound comes out.

Cheers,
Ulf

Ulf

Success. ‘Core Device Settings’ appears with the right settings - including the sampling rate at 44100. I now have sound.

Many thanks for your brilliance and persistence.

John

Excellent, I’m so glad that we could sort this out so easily :slight_smile:

Cheers,
Ulf

For future reference you can also run the cleanup script linked from the FAQ which will do this automatically: https://www.steinberg.net/forums/viewtopic.php?f=246&t=104450