[Solved] How to prevent Dorico from hiding upbeat pauses?

In a polyphonic context notated with two (or more) voices on the same staff, you often want the complete melodic line of the individual voices to be clearly visible by including pauses everywhere the voice isn’t sounding.

Dorico has a (default?) manner of hiding upbeat pauses that breaks this individual voice clarity. Sometimes this also leads to unwanted voice-flipping that has to be dealt with where it shouldn’t, as in the included example:

In the included example, Dorico auto-hides the blue “soprano” line upbeat pause, wich not only obscures the three-part structure but also makes the green “alto” part upbeat to be flipped with stem upwards.

I haven’t found a way of changing this “auto-hide upbeat pause” manner - is there a setting for this somewhere? If not, what is the best workaround?


(For clarity, this “photoshopped” image shows what I want Dorico to notate for me:)

Enter an explicit rest there…
Invoke the carat at the pickup beat.
Make sure Voice 1 is enabled.
Enable Force duration and rest input.
Enter any letter A-G to add the explicit rest.

Ah, thank you Craig!
I’ve tried using forced duration, but obviously not doing things in the right order… :slight_smile:

No problem. It’s one of those tricky things.

Or Y, which is the dedicated letter for rests and unpitched percussion notes :wink: