[SOLVED] IAA apps missing... why?

Can anybody tell me why a number of my IAA enabled apps do not show up in the Cubasis list of IAA apps and effects? They show up in other host apps’ lists, but not in Cubasis, and I’d like to know why.

Hi,

could you give us more information about your setup? iPad, iOS Version, do you use any interface?

Thanks!
RG

We would also need to know which IAAs are not showing up and are you using the latest version of Cubasis?

Thanks!
RG

I have an iPad Air 2, 128GB, iOS 8.x, latest version of Cubasis and the version before (I got the new update today but it’s the same as far as the IAA list is concerned). I sometimes use the iPad with the Focusrite iDock and/or a MIDI keyboard and sometimes just the iPad by itself, but it doesn’t change the IAA list either way.

I admit that I don’t really want to go through and figure out every single app that is missing, so I’ll start by giving you a few examples: Drums XD, Korg Module, and Guitarism. These apps show up and are usable in other hosts IAA lists but not in Cubasis, at least on my iPad.

Hope that helps. If you really need the entire inventory of missing apps I will go through the somewhat tedious process of compiling it, but I’d rather not.

I have Korg Module and it does not show up as IAA Midi instrument. What you have to do is create an audio track with input as IAA - Korg Module, then create a midi track and route the midi out to Korg module.

Perhaps this is the case for your other ‘missing’ apps also ?

We have the issue reproducible with Korg Module and evaluate the problem.

Workaround:
(1) Launch Cubasis
(2) Create a MIDI track
(3) Tap the instrument icon and choose “No Instrument”
(4) Open “Inspector” and tap “Routing”
(5) Tap “MIDI ouput” tab
(6) Choose “Module” from the list

I have noticed that this is affecting ALL of my korg products. So none of the following show up as IAA instrument, but they work with the workaround
Korg iMS-20
Korg iElectribe
Korg Module

Also affected but maybe by design are
Korg Gadget (This may be necessary because of the MIDI implementation in Gadget i.e you only get midi input on the selected gadget, this means gadget is only really useable within cubasis via sync to clock)
Rebirth. (Maybe because this has only recently had midi input to individual instruments added, previously only able to sync to clock)

@andyPlankton:

Besides Module (which i don’t have but seems the same) ALL korg apps are just IAA Generators and not IAA instruments.Of course they don’t show up in the instrument list.This is the most lazy IAA integration because the IAA generator is automatically supported if you update your app to the latest audiobus sdk.Basically,the Audiobus team did the work for them :wink:

The same counts for Rebirth (or Thor).

You have to open them on an Audiotrack.And route Midi to them from a seperate Midi track (if necessary)

@Crabman

That makes sense, cheers for the info :wink: I didn’t realise there where 2 forms of IAA sound maker (Generator and Instrument)

I had already sussed the workaround for myself, as a long term MIDI user I am used to having to think sideways sometimes :laughing:

Some things technology cannot change, I think it was Phil Oakey from the Human League who said of the sequencers and synths of the late 70’s and early 80’s

Getting all of this stuff working together is half of the fun

And I say, Long may the fun continue :smiley:

yep,sitting in the same boat…Just today i told to friend that making music on iOS is mainly waiting for the day where everything (that is supposed to work) JUST work without all the fuss.In the meantime you are wasting half of the time and creativity to look for workarrounds instead of making music…

Well,could be worse of course (looking at Win and Android tablets)

yeah I have had that bug too with technology…
Spending more time finding workarounds and killing creativity

Today I think we all need to be more disciplined when it comes to technology…
If it dont work, dont wait for the next update to resolve, send it back
Too many people put faith in future updates to resolve issues which allows for sloppy programming and bugs
in both hardware and software…

Also… if you experience bugs or inconsistencies let everyone know to avoid said hardware/Software to force makers to pay attention and fix.

I cant tell you how many times my creativity has been hindered by bugs and having to deal with finding workarounds for something that should just work…
Creativity is a delicate thing…
When your doing it,
It needs to be flowing without hindrance, because as soon as you hit that brick wall its gone…

Hi all,

Here is an example how to load Module to record MIDI and bounce audio afterwards.
Follow the same steps with other apps if required.

(1) Launch Korg Module
(2) Launch Cubasis
(3) Create a MIDI track
(4) Tap the instrument icon and choose “No Instrument”
(5) Open “Inspector” and tap “Routing”
(6) Tap “MIDI ouput” tab
(7) Choose “Module” from the list
(8) Tap “KEYS” button to trigger and record “Module” inside Cubasis.

Follow these steps to create an audio mixdown of your MIDI track created with Module:

(1) Create an audio track
(2) Tap “Mono input” in the Inspector Routing settings
(3) Tap “Inter-App” button in the “Audio Inputs” list and choose “Module”
(4) Make sure the audio track is selected and hit the record button

Please let me know if it helps to solve the issue.


Thanks

Lars

Thank you for this wealth of info folks. for some reason, I wasn’t getting any email though I set it up that way in my forum profile. I thought The thread had just died. I hope all the workarounds won’t be necessary soon. Let your developers know. Be polite but squeaky wheels. It’s one way users have to push things forward.

Being new to Cubasis, I didn’t even know the audio tracks had an IAA input button. THERE were all the “missing” apps. A MUCH bigger list than the MIDI track displays. I did know there were “instruments” and “generators” but I’m used to seeing them all on the same list.

For now, please go ahead and use the steps described above.
The issue is in evaluation for the upcoming Cubasis update.

Best,
Lars

In the progress of the upcoming Cubasis update the topic has been evaluated by our engineers with the following outcome:

The IAA apps that are not listed as instruments (only for audio track inputs) are in fact IAA generators (= only for audio tracks) and not IAA instruments, i.e. they cannot receive MIDI via IAA (only via CoreMIDI).

In summary, everything works as intended and no fix will be possible.


Best,
Lars

I just bought Cubasis yesterday. I noticed the In-App issue had come up on the AppStore reviews. So I’m glad to have seen this thread, keeping that in mind. All the info and workarounds worked well for me. Thanks guys. :slight_smile:

Not for Korg Module LE.
Not showing up in the IAA list of Audio-Track Input.
So my question: is this an Korg Module LE issue (simply having no IAA Gen) and it would work if I‘d buy
Korg Module??
Unfortunately nothing in the Korg AppDescriptions about IAA support.
So, could anyone tell me if Korg Module is working (still!) and Korg Module LE not?
(Maybe Korg killed their rudimentary IAA support completely?)
Thanks!! (Fast answer would help a lot, coz Korg is on 50% winter-sale currently :stuck_out_tongue:)

Hi whitelight,

Gave it a short check: For audio tracks, Module appears in the IAA list.
Nevertheless, I’d suggest to ask Korg about it.

Best,
Lars

Korg has great apps, but only with the lowest, completely outdated crap level of IAA audio integration, instead of AU audio with full recall settings including midi, or at least standard midi IAA compatibility.

This practically means:
for each of these apps you have to
a) create a midi track without instrument
b) create an audio track as IAA audio track
c) route the midi track to the Korg IAA audio track
d) record to the midi track and listen by activating the little speaker icon on the audio track.

Module runs without ay problems this way here, just like the other Korg apps, as far as I have them.