[SOLVED] IC Pro ipad & cubase 9.5.1 & windows 10 not connecting

Hi

My IC pro is working with my 9.0 version
but not with my 9.5.1 version

i re-installed SKI remote etc but it cant comunicate, although the app sees my studio computer.
I just cant properly connect, so it keep ‘loading’

remote SKI, IPAD (latest OS) and Cubase IC-pro (latest version) & Windows 10

same thing with me, will not connect to the desktop that appears in the app.

Same. Nuendo appears in app but keeps loading and in the end says it cannot connect.

Latest versions of Remote SKI, Nuendo 7, IPAD Air OS, Cubase IC-pro, Windows 10.

Any news on this problem, or is it just us?

It’s the same for me, works with cubase 9, doesn’t work with 9.5 :angry:

Still nothing…submitted a support request for it and was essentially told (after a 2-week wait) that support was too busy and to call them if I wanted actual help.

Really disappointed in all of this. It used to work well enough…not perfectly, but well enough. Now its just a useless iPad in the studio that I have to keep moving around.

Dear Steinberg Team,

Would you please be kind and tell us if our problem is an official issue or not?
I would like to know should I research more on my side or wait silently for the next update.

Kind regards

Hi all,

Thanks for your messages.

After exchanging with our engineering, it looks like Firewall settings lead to the connection problems.
Please give it a test to run iC Pro with deactivated Firewall setting, and share your results with us.

Thank you for your support.

Best,
Lars

Hi LSlowak,

Thank you for your kind response.

I disabled all firewalls on my DAW but iC Pro still fail to connect.

It shows my DAW in iC Pro and when it tries to connect, by pressing my DAW name or by entering the IP manually, it says “Operation Timmed Out: The operation couldn’t be completed.”

Nuendo 7.1.40 Build 250 + NEK (64bit), Windows 10 version 1709, iPad Air iOS 11.2.6.

Thank you for your support.

Kind regards

Is this still an issue with the latest iOS 11.3? I had to make sure that the Windows firewall (the only one I use) is allowing communication for Nuendo privately and publicly and I had to enter the IP manually.
But then it works with the latest app and the latest SKI installed. Have you made sure that Apple Bonjour is also installed - maybe together with the latest iTunes?

I am having a similar issue. It does connect, but it doesn’t update as I record. I get visual gaps in the timeline or the recorded event doesn’t show, or it shows but if I delete it on Cubase, it still shows, and so on. And then it will stop connecting or freezes. Something has gone very wrong!

Good wifi connection (I am just a few feet from the router), so I am not sure what is going on. This is on an iphone with the latest iOS and latest everything else. Windows 10.

I also have this problem - IC Pro works great with Cubase 9.0 but i upgraded to 9.5 a few days ago and it doesnt work there - even with the firewall turned off on my Win 10 machine. I track drums on my own so the iPad is great to allow this remotely from the control room. Sure I can go back to Cubase 9 for tracking my drums and allow icPro connectivity that way - but it seems a waste. I have the latest SKI and the latest icPro installed it seems… looks like something unique to Cubase 9.5. Would be great to get this resolved - thanks.

Any fix planned for this folks? Disabling the firewall on my Win 10 machine running cubase 9.5 did not solve the issue…
John

Hi all,

Sorry for the late reply.
Our quality assurance gave the issue a successful test, given the following environment:

  • iPad Pro 10.5"/iOS 11.4
  • Windows 10 Pro Redstone 1709 (Build 16299)
  • Cubase Pro 9.5.21
  • Cubase Pro 9.5.30 Build 192

If Cubase iC Pro did not find the computer, you may enter its IP manually via the appropriate dialogue.
The computer’s IP address can be found in Cubase’s studio setup/Steinberg SKI Remote dialogue.

Similar tests on Mac OS brought the same positive results.

Hope that helps.

Best,
Lars

I’m having problems to connect IC Pro with Cubase Pro 9.5 on Win 10, IPad 4 with iOS 10.3.3. It works with Cubase 9 and i can make it work with 9.5 when i disable the Firewall completly, but that is not a viable option.
Sadly the knowledge base link to the page that is supposed to explain how to set up the Firewall in Windows is broken.
Can somebody please help me with the setup of the Firewall?

Hi hannesrasmus,

Please try this link, which should work:
https://www.steinberg.net/en/support/knowledgebase_new/show_details/kb_show/cubase-ic-pro-troubleshooting/kb_back/2025.html

Best,
Lars

I have the solution!

I had this same problem and looked through all the forums and didnt find this solution

2 reasons it wont connect

1: the PC`s firewall , add the ipad pro as a trusted device in your antivirus software ( i use norton) yould need to find the ipads IP address on your network (look in the wifi section of setting)

2: When IC pro opens the option is " Enter IP of Computer" , this is incorrect because if you need to enter the IP address of Cubase on your computer which is different , this IP address is given to you after you install the remote SKi addon to cubase and its added as a remote device