[SOLVED] Import a Korg iM1 sound into existing midi track

I am new to iOS Cubasis and Korg iM1 and Audiobus
I’ve worked out how to use iM1 sounds in a new midi track on Cubasis
But I can’t see how to choose an iM1 instrument for an existing midi track in Cubasis
Is it possible ?
If so how please

If no other way works for you, simply

  • create an additional iM1 midi track as you always sucessfully did
  • drag and drop your midi clip(s) into that track.

Hi mikeconnectuk,

Here is also a short video from thesoundtestroom that might be helpful for you:
https://www.youtube.com/watch?v=jd7F72C4bUQ

Please let me know if it does!

Thanks,
Lars

Thanks very much for both suggestions …appreciated

I looked at YouTube link and will look for other videos there. But Lars I don’t seem to be able to add or change more than 1 track to iM1 track. See 2 images
It says already in use after I add the first track …?.


As far as I know, you can’t load such apps several times, like AU plugins or VSTis on PCs.

But if iM1 is multitimbral (I don’t have it installed), your best try would be to add it as one interapp audio track, and then create several midi tracks with output to separate midi out channels, routed to iM1 instruments listening to different midi channels, to get a kind of multitimbral mode.

This is how I work with multitimbral apps like IK Multimedia Sample tank. One problem remaining is that a mixdown of all these tracks to audio in one go still doesn’t work, and you can only mix down active tracks one by one separately to audio tracks - at least as far as I tried so far.

I guess things will work out fine, while iOS hardware gets better with each generation, and more and more synth apps offer AU format.

Deleted post

Sorry I posted too early
I cracked it
Set Korg iM1 to multi
Create audio track to iM1 for midi to play through
Create midi tracks with output inter app to iM1 and different channel per each track
Copy my midi data from original midi track to new track and assign instrument

Thanks for your help

Oh I’m giving up … I’ve created midi tracks with Korg iM1 as output to a separate channel each . But when I go to Korg iM1 and choose instrument for each channel , Cubasis doesn’t keep that instrument when I leave the Korg screen
Somebody pls help

Hi,

The following steps worked fine for me:

  • Launch Cubasis and create four MIDI tracks
  • Assign first MIDI track to iM1 (IAA)
  • Tap the instrument icon for MIDI track 2, 3 and 4 and choose “No instrument” for each track
  • Open the routing tab for MIDI track 2, 3 and 4, choose “iM1” as output and set the MIDI channel accordingly for each track

This setup allows me to trigger and record separate channels of iM1 in Cubasis.

Best,
Lars

Thanks Lars. That worked fine . One audio im1 track and all midi tracks routed to im1 with corresponding track numbers .
I did have a problem with im1 retaining my chosen instruments . Every time I stopped play and restarted the song , the instruments changed . Presumably some program control message being sent from the midi file. Cos I spend a lot of time remixing midi files so I don’t know what programme controls may be hidden in there . I solved it by disabling program control on all tracks in my im1 midi setup and saving the settings in the Im1 session

Thanks for the update!
Glad to hear it helped to solve the issue at your end.

Best,
Lars