Solved: Import Audio CD doesn't work.

Just for further information about this issue, the report I get when I look at driver-details of both my optical drives is the default microsoft and nothing else.
driver file detail.jpg

When you run the Gear installer, are you logged in with an account that has administrative privileges?
(e.g. “Run as Administrator …”)

Thanks for your suggestion - but no - Run as Administrator didn’t make any difference…
Still no solution :question:


Possible to step back in history/Windows to working version
or to clean Register and start over to find new hardware and drivers !?

regards S-EH

Problem solved! :mrgreen: :exclamation: :smiley:

I was right about the lack of UpperFilters in the registry. This fix for iTunes in Win XP did the trick:

After a lot of messing around I am relieved.

Thanks to all for trying to help


Well done and thanks for sharing the solution!

You’re most welcome - I’m certain this could help other in the future.

PG, is it possible to write “Solved” in front of the subject, that could be helpful later on?


If you go back to edit the very first post in the thread, you should be able to edit the subject name to say [Solved]

Right - did that!


Just to add to this, on Windows 10 be sure to disable autoplay! (Windows key + I, Devices, Autoplay, OFF). I just wasted a couple of hours thinking it was either my drive, or WaveLab. The issue was with an “enhanced” CD with both audio and data; after inserting the disc, Windows was spending about half an hour thrashing about trying to decide what to do with it, and apparently blocking other applications from accessing the drive while it did so.

The thing is, I thought I had disabled autoplay, but either it’s per drive and per disc type (!) or it got re-enabled after the 1607 update. I’ve also found it helps to disable Windows Defender on both my optical drives, i.e. add both drive letters (F:\ and G:\ in my case) to the exclusion list.