[SOLVED] Import midi file to iPad running cubasis

Hi folks, just bought cubasis for my iPad with the intent of just doing some simple midi note editing. My DAW is a windows pc where all my tracks reside. So the iPad makes a nice “go anywhere” editor. So step 1 is to export my midi from pic to my iPad. I have tried emailing the midi file to myself, get the iPad to load the attachment and toss it into cubasis. Now cubasis seems to get the file ok but I can’t see anywhere where the tracks reside for editing. I also tried iclouding the file over with the exact same results. I’ve tried many such imports and I see a small white banner on the top left with the file name and a (x) where x is the number of imports I’ve done. So that’s why I think the data is getting in the iPad cubasis, but heck if I can play or edit anything. There are only blank tracks. Anyone know what I am doing wrong?

Hi Joeloduca,

Could not confirmed here, midifile import works as expected.

Please import the attached midi file into cubasis.
All midi notes should be inside the midi event.
It looks like that your midi file is broken or you convert to the wrong midifile format.

best jan
debussy.zip (9.71 KB)

Thanks Hiltmann for the reply… That is an interesting thought you have… I never really thought about the 2 versions of midi files. Mine in particular was, (I think its called a version2 file). Its a multitrack midi file with only 2 midi tracks. (piano and bass). But by your post, I am estimating that your attachment MIDI file is one that you successfully imported and if I could in fact import YOUR midi file into my IPAD, well then I would have some sort of midi format issue with MY file. But actually yours didn’t work for me either. Just to kind of see what we are dealing with, I imported YOUR midi file into some music printing app, Looks like a piano track in the key of E. So I know you have a good MIDI file there… I know I do as well because I too have loaded my MIDI file with other apps and get what I played… --another strange fact is, with your MIDI file, I dont see the white banner at the top left of cubasis telling me of any import that it’s doing… I just simply emailed your midi file to myself. Went into email, loaded the attachment and sent it to Cubasis on my ipad. Also forgot to mention in any of my posts, When I look at the “MEDIA” section of the app, I ONLY have T file (I assume Templates) and then I have a few project files that were DEMOs that the app came with… So I have NO SUCH files showing there that were my midi files that I imported…

Hi Joeloduca,

I can’t confirm your issue, here are my step by step description :

  • download attached debussy.zip
  • send debussy.zip as E-Mail to my Mail account
  • open on iPAD Air 2, iOS 10.3.1 my Mail with attached debussy.zip
  • select “import with Cubasis”

Result :

  • debussy.zip is imported to cubasis to > Media/Midi/ “debussy”

  • double click on Media/Midi/ “debussy” open the midi file inside the current project on the selected midi track

  • select Media/Midi/ “debussy” file and drag it to the target midi track will move it to the target midi track

  • all midi notes are available, midi file import via E-Mail works as expected

Please can you send us an step by step description that we can reproduce your issue.

best greetings

Hello Jan Hiltmann, many thanks for your reply… It sounds very much like I am doing the same thing you are from your description. I tried to attach some screen prints from my ipad of all I am doing… I also want to mention, I am using an ipad pro. Do you think there are any issues with that? I also tried a little different variation but with the same exact result: I emailed your .zip file and imported that straight into cubasis. The previous attempts were me extracting the midi from the zip file and emailing that midi file to myself and importing. I do get a quick white banner below the “media” at the top left. So the import is getting to cubasis… When i do multiple imports, I get the filename(x).zip where x is the number of imports. But take a look at the 3rd screen shot. I think your filename was something like debassy.zip… I would think I should see a debassy.mid or something of a midi file there. And I don’t and I never saw one… I’ve tried every which way I can think of to examine or even find this file that it apparently imported… But I just can’t seem to find it in memory. Hope this helps…

have a great day!
archive (1).zip (1.11 MB)

Hello Jan Hiltmann, Hey I figured it out. Its all working fine. I noticed a midi section within the Media view. So now I see the 10 thousand import attempts I made. LOL.

Thank you for all your help!!

Hi Joeloduca,

Its all working fine.

Thanks for the Info.

best Jan