[SOLVED] Importing audio, problems with loop tempo & pitch

I’d like to import loops to the project retaining the way they sound outside Cubase. Loops play and align to the project tempo correctly in Loop Browser, i.e. loops sound the same as outside Cubase.

However, when I try to import them to pool or arrangement (drag & drop from file manager, import to pool, import to project, import from Loop Browser), they emerge as slower with a lower pitch. Tried turning off Musical mode in both Pool and Track to no avail.

What am I doing wrong? :confused:


Does this happen to anyone else? To me it’s a mystery. Everything else runs smoothly, but all of a sudden (since 7.5.3) I can’t really use loops anymore. Which is awkward to say the least, i.e. dragging loops into project for a preview isn’t an option.

Ps. I created a support request last week, but have not heard back from Steinberg yet.

Check sample rates of loops versus your project settings?

you say that you want loops to play the same as outside cubase.

that would indicate that you want no tempo matching, if that is correct.

when you import loops they will stretch but should not pitch, by default.

if you getting a big change you probably have a big difference in tempos, that would be my guess.

Classic, this. Thanks guys. Nothing to see here anymore, carry on. :blush:

Ps. I’ve no idea when, but I had messed up the template’s sample rate & bit depth at some point. I also thought I already checked for this, but your post made me double check.

Pps. Beerbong: Yeah, I was a bit unclear. I actually set the tempo of the project according to the loop that I found fit right from the get go. It was “mysterious” when the loop played alright everywhere else, except in the project.


Yeah man. I’m sure we’ve all been burnt by this many times—hunting around for obscure causes while it was friggin samplerate.

Bloody hell, though… Cubase should instantly convert the audio upon import to the sample rate of the current project! Why wouldn’t one want that?

I think if you tick of “automatically adjust sample rate / but depth” and “don’t ask again,” it will do just that.


I’m not at the DAW atm, but I’m probably going to need also…
preferences - editing -audio
processing shared clips - open option dialogue
…i.e. to resolve the case of premature don’t ask again.

Ah, premature don’t-ask-again… it happens to all of us sometimes. :wink: