[Solved] In-app Purchase Error

Running an iPad Mini 4 with a CME X-key 25 through a usb3 camera adapter.

I was able to unlock the demo mode for Cubasis LE when I plugged in my XKey. Then I tried to make the in-app purchase (upgrade) to full Cubasis (or Cubasis LE with full feature set), but I keep getting an “In-app purchase error.” I have a brand new iPad and have not yet made an in-app purchase on it so I am not certain that it is a Cubasis issue alone.

Lars? Someone? Help.


Hi Future Aztec,

Thanks for your message.

Since you’ve successfully unlocked the feature set of Cubasis LE, you’re entitled to see and purchase additional in-app purchases.
So far we are not aware of any in-app purchase issue, neither with Cubasis nor Cubasis LE.

Please have a look at the following Apple article, which hopefully helps to get around the issue:

Please keep me updated.



I updated everything that might need updating in my apple id settings, thinking maybe something was wrong there. Still couldn’t make the in-app purchase. So I decided to buy another app from the store to make sure it worked. I bought a synth from Audio Damage and had no problem.


I deleted Cubasis 2 LE, redownloaded it from the app store, unlocked the demo, went to do the in-app purchase…same error.



So remembered I had an old iPhone someone gave me a month ago that was tied in with my iCloud, etc. It was sitting in the corner dead, so I charged it up and went through and reentered all my payment info on this device and logged out of everything and logged back in. I think the issue was not having all of the info on my three apple devices completely in sync. Very happy to have this solved and super stoked to now be able to be apart of the Cubasis community.

Have a great day Lars!

Thanks for the update, Future Aztec!
Glad to hear the problem could be solved.

Have great fun using Cubasis!