*Solved* Invisible/Missing Bars Rests

I am hoping that some clever chap can assist me with this problem. Attached to this post is a small dorico file of the choir part to the UK national anthem. The main orchestration comprises of the Gordon Jacob brass fanfare, the first verse (using standard harmony) and then a second verse using Jacob harmony. The file was an xml import from Sibelius and you can see there are no visible bars rest between bars 1 and 13.

NB: I have inserted one note in bar 1 (during my attempts to fix this, but to no avail). When it is removed the whole introduction is squished down (write mode). In Engrave mode it does exactly the same.

I have already tried Setup>Layout Options (selected Players) and have selected the part and ‘all’ then toggled the ‘Show bars rests in empty bars’ (which is on) but this did nothing.

Could anybody please figure out what I’ve done wrong?

NB: The rest were not invisible in the Sib 6 file prior to xml export (Doliet 6)

Thank you
Choir-UK National Anthem-rests missing.zip (267 KB)

The ‘Show bar rests in empty bars’ option is switched off in the ‘Full score’ layout – if you switch it back on, the bar rests reappear.

Daniel,

thank you so much for your quick response.

Sorry about that small oversight however, when I do switch it on I can only see the rests on the treble stave of the part and if I delete the dotted minim G, then all the rest are removed once more. Could this be a problem with just my system. I’ll perform a ‘cold boot’ and retest. I will edit this post with my results.

*** After reboot the same problem exists ***

Thank you again.

Regards

Dave

Try also selecting the first notes of each of the SA/TB voices and making sure that ‘Starts voice’ is switched off in Properties.

Daniel,

Thank you so much. That was it!

It will take time for most of us to become as fluent on Dorico as we have been with our previous software. Thank you once again for your patience and understanding.

Regards

Dave

I’m having the same problem, I want bar rests to appear in the upstem voice in the treble clef for the first two measure here. “Show bar rests in empty bars” is selected in Layout options, “starts voice” is deselected, and “show bar rests” is selected in Notation options. I’m a little bit confused about the difference between “show bar rests” in layout options vs. notation options. Surely they don’t cancel each other out :slight_smile:
missing bar rests.zip (438 KB)

Edit, see pianoleos answer below, that is the right way to do it.

Hi,

Until the other voice beggins there are no implicit rests for Dorico to show, and if you enter a explicit rest it’ll allign with notes of the other voice at the same rhytmic position and will not show at the middle of the bar.
Maybe a solution for this strict counterpoint situation could be an option to display an explicit “bar rest” in the same position as an implicit bar rest.

If you have no option but to show the rest in all voices from the beginning, i think that you need a workaround.

First, in notation options select to show every rest in each voice, and to show bar rests in aditional voices (the difference with layout options is that there you choose to show bar rests in empty bars).
In the engraving options set the default gap before mid-system coda section to 0 spaces.
Add a bar before the first one and enter there a explicit rest, for every voice at best.
At the beggining of the now second bar insert a coda (hide it in the properties panel) and a bar number change so it can be displayed as #1;
In engrave mode insert a frame break, remove the overrides in page 2 and insert a Master page change to use the first master page there too.
That’s it.

Maybe an easier workaround is to enter a explicit whole rest in the first bar of your up-stem voice, and set the custom scale to 1, then create a playing technique with the whole rest sign and position it where you need it in engrave mode.

There’s no need for a workaround. Use explicit bar rests.

As to your confusion, Graham, it’s not a case of Notation Options and Layout Options cancelling each other out; it’s just that the Up-Stem Voice 1 doesn’t actually exist until bar 3 as far as Dorico’s concerned. Using Shift-B Rest Enter (or the Insert Bar Rest button in the Bars and Barlines section of the right panel) tells Dorico to start the voice early.

Super!
Thanks Leo.

Still, the way Dorico is handling this, is not consitent and the options and properties, which have been mentioned here, are misleading in this case. This is one of the questions I get asked very often from people, who normally write two voices in one system (especially church musicians).

Thanks Leo, I love how simple the solution is. I couldn’t find this technique because I didn’t know that’s what I was looking for. Maybe the manual should mention something about this on the page about “show empty bars”.

The entry in the manual for this is here - I’ve already reworked it a bit “in-house” to have a more useful title and some additional information about how this interacts with the Notation Option for hiding/showing bar rests in additional voices. I’ll be publishing an update soon which will include that.

When you say it would be useful to mention this on the page about “show empty bars” - do you mean the task about hiding/showing bar rests in empty bars? If so, I think I agree and have added a link to the task to that page that will also be included in the next update.

Ok fantastic. I was trying to show a bar rest in a different voice at the beginning of the piece and found this page: https://steinberg.help/dorico/v1/en/dorico/topics/notation_reference/notation_reference_cues_rests_bar_rests_hiding_showing_t.html

…which didn’t solve my problem, what I actually needed to do was input the bar rest with the caret, but I didn’t think to do that.

Good to know, thanks - yeah, that page is about hiding/showing bar rests relating to cues specifically, and is from the v1 manual which hasn’t been updated for a while; annoyingly, search results frequently point to older docs because they’ve been around longer. It’s something we’re aware of and we’re looking into ways of making it more obvious when you’ve landed on a page that isn’t from the latest manual.

Thanks for the link - if that’s coming up when people search for relevant info for hiding bar rests, I’ll see if I can link this up too.

Sorry, but as far as I can tell, if I choose “Show rhythms in tablature” in layout options (under Players|Fretted Instruments) the bar rests disappear.

Unchecking “Show rhythms in tablature” causes them to reappear. Any suggestions to get them to show while also showing rhythms in the TAB staff?

(I’m in 3.5. I’ll update my signature)

This is a little bug, falhousen, which will be fixed in the next update, when it arrives.