[SOLVED] Lyrics Vertical Spacing To Avoid Staff Collision

Hello,

When entering lyrics, is there a way to automatically space a staff below the lyrics?

Presently, when I enter lyrics they collide with the staff below so the lyrics appear over the notes and staff-lines. I have found how to manually drag a staff down so lyrics have their own space on a page by page basis.

Alternatively, how can I set a staff position from a certain point on or for a selection to accommodate the lyrics.

Thanks.

You must be in galley view. I do not think this can happen in page view. You can change the percentage of space between space in galley view in Layout options — vertical spacing, I personally increase it a lot when I have to deal with lyrics.


Hope it helps !

Marc

Hello Marc,

Thanks for your reply. I’m definitely in Page view.

I switched to galley view to check and the lyrics are in their own space there in between the other staves. When I switched back to page view my manual spacing of the staves had been undone and all the lyrics collisions were back so they cover the lines and notes of the stave below again.

So, from your reply, I take it that entering lyrics in page view should adjust the stave below to avoid collision?

Thanks

I am wondering if you are inputing lyrics on staves which are labeled as a singer (soprano, tenor or whatever, in the singer category, when you choose the instrument)… I have written different pieces of music with singers (being a professional singer myself) and Dorico has always perfectly moved the staves so that no collision with the lyrics could happen… except in galley view, which is more a “work in progress” mode (no layout problems involved). Hence my first remark.

I just tried adding lyrics to a bassoon staff, and everything still spaced correctly, just like the singer staves … :slight_smile:

Ok, fratveno :wink:
I must admit I never tried that ! So maybe ClassicMan should zip and upload its project here, so that Daniel could have a look and explain what went wrong ?

Hello Marc and fratveno,

Thank you for your replies. I’ve found out a little more.

If I use one of Dorico’s templates as provided the lyrics spacing works. If I add another player in ‘Setup’ mode or move a player to a different position the lyrics spacing stops working.

Similarly, if I prepare my own score setup then lyrics spacing doesn’t work.

As requested, I’ve uploaded a zip file containg a short sample score and an image of the problem. I hope someone from the team will be able to suggest how to fix this.

Dorico Lyrics Problem Sample.zip

Thanks

Go to layout options (shift ctrl L) and page setup. Choose space size : rastral size 7 (4.8mm) and you will see it is almost perfect ! I have changed to space size : 3.10 and now it is really perfect.
Dorico does not choose the space size for you and it is one of the most powerful commands in this program :wink:

Hello Marc,

Well … this is fantastic. One click of a button and the score spaces out beautifully. :smiley:

One more question, the title page, or first system needs different spacing to the other pages/systems due to the titles etc. Apart from manually dragging down the staves, is there another way to manage this?

Thanks for your help it’s very much appreciated.

You should use the layout tools in engrave mode to let Dorico do its magic. In the title pages, Dorico automatically inputs the title that you fill in File — Project info. If you double click in the text frame dedicated to titles in First pages (right column, in engrave mode), you will notice the title token {@flowTitle@}. There are plenty of tokens available and you are free to add them, to change the text frames as you wish, and so on…
The music will only be engraved in the music frames, so if the text frames do not overlap with the music frames, you should have no problem. Let us know if this all seem strange to you.
I suggest you watch the little video tutorials like https://www.youtube.com/watch?v=SxNY15vT7dQ