[SOLVED] Mac Monterey 12.6.9 no longer recognizing the UR824


I’ve recently upgraded to Monterey 12.6.9 from the previous version, and the UR824 is no longer recognized by the system. dspMixFx_UR824 can see it, but not the system’s out controls and Sound control panel. Dorico can’t see it, as well.

Any idea of how to solve it? I’ve reinstalled the latest software, checked with the extension authentication, restarted the Mac, but there is no chance I can let it see the audio interface.


Maybe my problem is not due to kext authentication. This is what the Mac system profiler says:


  Versione:	3.1.4
  Ultima modifica:	04/11/22, 05:53
  ID bundle:	jp.co.yamaha.driver.YamahaSteinbergUSBAudio314
  Autenticata:	Sì
  Caricata:	No
  Ottenuta da:	Sviluppatore identificato
  Tipo:	Universale
  Architetture:	arm64e, x86_64
  64 bit (Intel):	Sì
  Posizione:	/Library/Extensions/YamahaSteinbergUSBAudio314.kext
  Versione kext:	3.1.4
  Caricabile:	Sì
  Dipendenze:	Soddisfatte
  Firmata da:	Developer ID Application: Yamaha Corporation (5LE7A8CF65), Developer ID Certification Authority, Apple Root CA

It says that the extension is authenticated (and there is also the Yamaha ID: 5LE7A8CF65 I was looking for).

But it is not loaded. Why not? How to make the system load it?


Where should the Yamaha driver be installed on a Mac (Monterey)?

In some manuals I find that it should be inside System/Library/Extensions/.

In my system is, and apparently has always been, inside /Library/Extensions/.

Is this correct? It worked, until the latest OS update.


I’ve tried manually loading the Yamaha driver, by typing

sudo kextload /Library/Extensions/YamahaSteinbergUSBAudio.kext

This didn’t work, and resulted in the following error (line breaks added for easier readability):

Executing: /usr/bin/kmutil load -p /Library/Extensions/YamahaSteinbergUSBAudio.kext

Error Domain=KMErrorDomain Code=71 "Loading extension failed: Unable to create extension from bundle: codeless (missing CFBundlePackageType) bundle (nil) at /Library/Extensions/YamahaSteinbergUSBAudio.kext" 

UserInfo={NSLocalizedDescription=Loading extension failed: Unable to create extension from bundle: codeless (missing CFBundlePackageType) bundle (nil) at /Library/Extensions/YamahaSteinbergUSBAudio.kext}

What does it mean?


My Mac system profilers says this about the disabled driver:

No user, consent, but spctl kext-consent list says the Yamaha team is allowed (even too much: it is now listed twice, after my latest attempt to manually authorize it):


What’s going on?


Still not working, against any logic.

  1. I booted in Recovery mode, and removed the duplicated Team Identifiers with the spctl kext-consent remove command. I then added the Teams again with the spctl kext-consent add command. Now it looks fine with a spctl kext-consent list command:
Allowed Team Identifiers:
  1. Still in Recovery mode, I removed protection to kext loading with the command csrutil enable --without kext. This should be still safe against external attacks. It is deprecated by Apple as unsupported and risky, but it shouldn’t be until I stay in Monterey.

  2. I uninstalled, then reinstalled the Yamaha driver v3.1.4. Rebooted the Mac twice.

  3. I set the UR824 to normal mode. dspMixFx can see it. The Mac can’t. The Yamaha driver is still listed among the disable softwares, to which I didn’t give consent. The Terminal says otherwise.

So, I’ve gone under the hood, but the issue persists. Any hint would be really appreciated.


Just updated to Monterey 12.7.0, and after a few minutes trying between the Sound Preferences, the System Profiler, the Terminal, the UR824 (normal mode) reappeared to the system.

Maybe this OS update, issues just ten days after the previous, has fixed what was broken?


OK, so I updated to 12.7 but I haven’t yet been able to connect to my UR824. Any suggestions on specific ways to get there?

I don’t know exactly. All I’ve done is to connect my Mac and UR824 with a USB cable. Install the dedicated Steinberg Tools (the latest ones for Monterey also include the latest Yamaha driver).

The UR824 appeared as a system sound device, and could be seen by the dedicated dspMixFx console.

If the software works, it should be all it has to be done.


I figured it out. Cubase tells us about it in the download instructions. Mac put in a new ‘Security and Privacy’ step where you have to give permission for the driver to be recognized.

I’ve installed the new Yamaha driver v3.1.6, together with the new MacOS Monterey 12.7.1.

As a result, the UR284 disappeared again from the Mac. dspMixFx could see it. All was again as I described in my early posts.

Installing the Yamaha driver v3.1.4 solved the issue. The Mac can now see the UR248.

I’ve no idea if this issue was caused by the Yamaha driver of the OS update, but the previous Yamaha driver works fine, so I tend to suspect the new driver.

I could do another test, installing the driver v3.1.6 again, but I’m frankly too afraid to break something that is now working. So, I’ll leave it to Steinberg and Yamaha, if they want.

It’s not really new, since this has been happening for some MacOS versions, now. The procedure described by Steinberg didn’t work in my system, since the Allow button never appeared. But I allowed it manually, as described in this thread. So, that’s not the problem in my case.