SOLVED Macro Key Commands Problem

Hey fellas would you check on your system the ability to make a KEY COMMAND for the MACRO.

It is allowing me to select the key for the MACRO but wont assign it when trying here.

Thanks

I’m still on 10.0.60 but indeed, the thing is broken, here. When attempting to assign a key command (Ctrl+Alt+0, in example, which isn’t usually assigned, here), nothing happens when clicking on the Assign button, this, even if everything is folded in the Commands list above the Macros one.

Naively, I thought that this is the kind of thing that was supposed to be fixed in 10.5, with the new window… :unamused:

EDIT - And there is something that I never saw until now : on the bottom of the keys assigned list, ther is a very tiny arrow (at first, I thought it was a piece of dust on my screen… :laughing: ) which actually shows a ‘Find command in tree’ zone : clicking on it does nothing… :confused:

:sunglasses:

Working here
Cubase 10.5.12 - Windows 10 pro

Delta

Care to post a step by step in case we are missing something?

I tried assigning a key command to the default Macros and no go here

In Key Commands window:
Search for created macro’s name
Select if not selected
Click on field near Assign
Type combination of keys
Assign

Works for me here.

Pardon my stupidity here. :open_mouth: Ima blame it on da pandemic :mrgreen:

ERROR: I created the Macro just fine.

  1. I forget that you have to go to the KEY COMMANDS section, search for the MACRO you created then
  2. New macro shows there in the COMMANDS window which you then add your KEY COMMAND to the Macro.

There must be something different from 10.0.x, then, because it still doesn’t work, here.

I don’t have any Key commands section (list ?), here. I have these three : Commands, Keys and Macros. Creating a new macro still doesn’t allow me to assign the Ctrl+Alt+0 key combination previously tested, and i’m sure that it isn’t used somewhere else.

From what I see in the 10.5 online help, the only difference between the two versions is the added block allowing to manage the commands included in a given macro (in the Macros section), and the Select option (in the Keys section) which doesn’t appear as so in 10.0.x…

So, I would appreciate to be enlighten, from someone who is still on 10.0.x : is it possible to assign a key combination to a newly created macro and, if so, how ?

EDIT : I GOT IT ALSO (and another pandemic victim… :mrgreen:) ! Actually, it’s in the Commands section where the newly created macro should be selected (Macros folder). Selecting it directly in the Macros list doesn’t work. So, next time, I’ll make a more in depth RTFM session first. Can’t prevent myself from wondering where is the logic of this, though… :confused:

If someone told me they haven’t fallen for it even once, I wouldn’t believe them.

:mrgreen:

DATS what I was tryin to say. Nope you cant assign the key command directly to the macro in the macro section which makes zero LOGICAL sense, you have to go to the command section up top, go to the macro folder and then assign it there once you have created the Macro down at the bottom, very ODD I must say

I have been cycling and walking a lot so that may be part of my issue :open_mouth: