[SOLVED] Midi clock 1.4

Well where to start… NO SYNC at all … Tried it with drumjam with no luck , the beat is always out of rhythm with my music , I muted all the tracks and turn on the metronome THERE ARE NO SYNC … :frowning: :astonished:

I do get midi clock, both on a harware out and a virtual port.

Audiobus output: cubasis
Audiobus input: sunrizer
Sunrizer receive midi clock.
Cubasis send midiclock 132 bpm.
Sunrizer sync and the resulting bpm is : 2147483647…

Wow thats fast! :open_mouth:

Maybe there is something wrong?


Trying with the nlog synth.
The arpeggiator reacts to the midiclock but the note on message came in a variation of a half second.
There is not stable timing.


Alchemy gets the midiclock and its result in 999 bpm.


The midi clock looks correct, at 120 bmp we should get an event every 20.8 msec, and that’s what I see in MidiVision.

Alchemy is probably buggy.
Some apps seems to receive only the start stop message, weird.

Animoog is ok if I set the input to cubasis.

Problem is that cubasis is sending the clock to all ports which is a bad idea, best way to get double clock speed.

thanks for pointing me to animoog.
it works as it should.

Hey steinberg support plz any recommendation ??

Hi All,

We successfully tested the following apps as “MIDI clock slaves”:

  • iElectribe
  • iElectribe Gorillaz
  • Funkbox
  • Bassline
  • and the Korg Electribe SX hardware.

DrumJam is reproducably not in sync when using it as a MIDI clock slave with Cubasis as a MIDI clock master. This is how we tested it:

  1. Launch Cubasis and enable “Send MIDI Clock” in the setup.
  2. Create a new empty project without any tracks.
  3. Enable the metronome.
  4. Launch DrumJam, enable MIDI Clock input in the setup and configure it to play a drum pattern.
  5. Start playback in Cubasis.
    Result: DrumJam starts way too late and lags behind Cubasis’ metronome.

Since other apps and external hardware is in sync with Cubasis’ MIDI clock signals, everything seems to indicate that this is not a Cubasis issue.

As a workaround, use Cubasis not as a MIDI clock master but as a MIDI input by sending the notes directly to the other app:

  1. Launch Cubasis, create a MIDI track with the notes you want DrumJam to play.
  2. In the Inspector’s MIDI Connections panel, set DrumJam as the output port.
  3. In DrumJam, clear the pattern (remove all instruments) and enable MIDI input from Cubasis in the setup.
  4. Start playback in Cubasis.
    4b. If you don’t want to hear Cubasis’ internal sounds, assign “No Instrument” to the MIDI track.
    Result: DrumJam plays the notes written in Cubasis in sync.

Please also have a look at this thread: http://www.steinberg.net/forum/viewtopic.php?f=183&t=40220

best regards
Jan Hiltmann
Test Engineer

Thanks Jan for testing.