[SOLVED] MIDI Controller won't record

I’ve searched high and low for an answer to this to no avail so I thought I’d ask here.

My problem:
My MIDI Controller (Alesis Q25) is not recording on a MIDI track.

Useful information to note:
When I am not recording I can use the controller just fine. I can load up a VSTi and hear it to monitor, both within and outside of Cubase. When I hit record however the monitoring stops and no MIDI information gets recorded. I can see MIDI activity happening in the Transport Bar while record is active. I am set to channel 1 on both the track input and the controller. I have tried “All MIDI Inputs” too. I have tried with "Use System Timestamp for ‘Windows MIDI’ Inputs. I have tried going in via the MIDI port on my UR22 MkII. The virtual keyboard does not record any information either.

Based on the above information I have narrowed it down to something within Cubase. Any help would most most appreciated.


In the Preferences > MIDI > MIDI Filter, Make sure, now is not filtered out for Record, please.

You, Sir, are a hero!

It turns out I’m stupid, and I’d seen this in previous threads and assumed that ticked meant enabled, and not filtered out.