*SOLVED* MIDI Editing Channel Enable Behavior


On Cubase 8.5, the program would automatically enable the MIDI channel you chose to edit. Is there any way to enable this behavior in Cubase 9?

Example: I would chose any clip to edit and automatically I would be able to play it with the midi controller. Now, I open the key editor and I still hear the channel that I was previously on.



To me it sounds like different Preferences Setup. You can set Cubase so that relevant Channel is selected, when you select a Part. Then, once the Channel is selected, the Record Enabled is enabled automatically (if you set it up like this in Preferences – this is actually the default preferences settings), so you can hear what you play on your MIDI keyboard.


It seems they changed that default in C9, it wasn’t like that in 8.5. I’ve been trying to find it in preferences but no luck.


The default settings didn’t change. Maybe you had this settings with C8.5 and the preferences didn’t migrate correct to your Cubase 9.

The Preferences I’m pointing to is this:
Editing > Track Selection Follows Event Selection
Editing > Project & MixConsole > Enable Record on Selected MIDI Track.


Those settings are enabled but still no luck.

Compared the settings from 8.5. to 9, and still can’t find how to fix this.

It works as you want out of the box here, so I can’t add much.

What folder should I import from 8.5 to duplicate the settings?

%AppData%/Steinberg/Cubase 8.5.

The file path to the prefs folder for 64bit Windows is %AppData%\Steinberg\Cubase 8.5_64

This is very unusual. I’ve always enjoyed the fact that Cubase automatically let’s you play the instrument you’re editing in the Key Editor, and once you close that window you’re back to the other instrument.

I was able to have the track selection follow whatever I click on, but it’s not the behavior from 8.5.

Hopefully it’s just a bug. Going to uninstall it and reinstall to see if it fixes it.

Also take a look at this setting: Preferences > VST > Auto Monitoring and choose the one that fits your way of working best. ‘Tapemachine Style’ works best for me overall. When you select a track it automatically enables monitoring during stop and record, but not during playback.

Tried re-installing Cubase 9.0.3 but still no luck with this. Hopefully C9.5 fixes this for me.

Okay… figured it out! There’s a button on the top left of the editor that says: “Record In Editor”. There we go! :smiley:

Thanks for all the help!