[SOLVED] MIDI keyboard doesn't work in Dorico

I want to use my Behringer U-Control UMX49 keyboard for note input in Dorico. But Dorico doesn’t recognize it (while I can use it in Finale and MuseScore). Am I missing any settings in Dorico to make my keyboard work?


You should find that simply plugging in your MIDI keyboard before running Dorico is sufficient to make it work; there are no settings in Dorico at present for choosing which MIDI input device it should use.

Thank you, Daniel,
then I will wait until the Hamburg team may find out why my keyboard doesn’t work in Dorico.


Was it plugged in and turned on before you launched Dorico?


Hi Thomas,

I think you might need to go the menu , Write mode, and tick “Note Input” or double-click on the first rest where you see the caret blinking and start playing your midi keyboard.

I was confused like you as well, as to why my MIDI keyboard “didn’t” work.

Hi Thomas,
could you please send us the VSTAudioEngine log files? On Win you’ll find them under C:\Users<yourname>\AppData\Local\Temp\VSTAudioEngine, on Mac under $TMPDIR/VSTAudioEngine.
Also, connect your U-Control, start Dorico, create an empty project, save it and then zip everything up and post here.
Thanks for collaboration,

I did what you suggested. You’ll find the zipped files in the attachment.

Thank you for your help.

Test.dorico.zip (196 KB)
log3.txt.zip (1.72 KB)
application.log.zip (1.42 KB)

following up on gideonlongs suggestion, input the first note with the mouse and then see if you can go on inputting via midi keys, that works for me

Delgado and Gideonlong,

that doesn’t work for me. I can input notes with the mouse or the computer keyboard (letters a … g) but not with the MIDI keyboard. And it does not depend on when I start using the MIDI keyboard.


Hi Thomas,

thanks very much for the uploaded files. Now, looking at them, it seems that the audio engine is crashing soon after startup of Dorico. First the log file looks normal and then it suddenly breaks off. Also, in the Dorico project file then all the audio engine status data is completely missing. So this leads me to the assumption that the audio engine either crashes or is hanging.

In the Activity Monitor application, do you see a VSTAudioEngine process running? Probably not.

Could you please open the Console application and look for crash reports of the VSTAudioEngine process. I don’t have a Mac right at my fingertips, but I think you should find them under ‘Diagnostic Reports’ or so.

Such a crash report shall gives us a clearer picture of where and why it’s crashing. Could be that audio engine “doesn’t like” U-Control, but I guess/hope not. But could you also try to disconnect the U-Controt, then start Dorico and see if under that circumstance the VSTAudioEngine runs continuously?


Hi Ulf,

VSTAudioEngine is running as you can see from the attached png-snippet of the Activity Monitor.

I also attached a crashlog file from the VSTAudioEngine. But this seems to be from a session when I tried to open a saved Dorico file (which ended up at 50 % loading with a crash of Dorico - you might have heard of this bug).
Currently there is no recent crashlog file from today - but the keyboard doesn’t work.

VSTAudioEngine_2016-10-24-144024_iMac-Thomas.crash.zip (18.7 KB)
VSTEngine.png.zip (6.77 KB)

Hi Thomas,
okay, so the audio engine is running but still no keyboard input. But if the audio engine is running, then also log files will get written. The last log file I saw from you suddenly ended for no reason, that’s why I suspected a crash, but as we’ve found out, the engine is running.
So could you please again have a look for the audio engine’s log files ($TMPDIR/VSTAudioEngine) and zip up everything that you can find there? Also, a simple Dorico project would be nice. E.g. connect the U-control, start Dorico, create a Piano project but no actual notes inside. Save that project, zip it up and attach here.


P.S.: Sure, I heard about the crash at 50% loading.

Hi Ulf,

Daniel wrote me that you’re on holiday this week - so please don’t forget to relax!

And next week you might have a look at the attached Dorico and log files.

Thank you,

Test.dorico.zip (196 KB)
log3.txt.zip (3.68 KB)
application.log.zip (3.65 KB)

This might be usefull too - see attachment.

VSTAudioEngine_2016-10-26-152540_iMac-Thomas.wakeups_resource.diag.zip (5.41 KB)

Hi Thomas,
again, I’ve had a look at the most recent files you’ve posted and there everything looks quite normal. Well, apart from the fact, that the audio engine only finds 1 MIDI device and that is ‘IAC Driver IAC-Bus 1’. I’m not so familiar on Mac, nor do I know the Behringer U-Control. From what I read, the IAC Driver is for virtual MIDI ports so that you can stream MIDI between separated applications. How about the Behringer keyboard, shouldn’t it appear as an own MIDI device? Can you have a look under the system preferences under “Audio MIDI Setup”, is there the Behringer device listed?
Also, do you run Dorico and Finale/MuseScore in parallel? Maybe they claim the Behringer device for themselves, so that Dorico can’t access it. Could you try closing everything else and then just run Dorico?

Hi Ulf,

good news: note input with my MIDI keyboard works now in Dorico!

I setup a new MIDI configuration in the Mac OS MIDI Studio. I then deleted the IAC Driver in this configuration. So there’s only my Behringer keyboard left.

I did a restart of Dorico and note input with the MIDI keyboard works. I even hear a sound while inputting notes, although Paul mentioned in another thread that this feature is not included in Dorico 1.0.

Thank you so much for your help and the hint with the IAC driver.


Excellent, very glad to hear you’ve made some progress.

I am having the same problem. I’m using a Kurzweil with a MIDI/USB connection with no external interface. The USB is listed in Dorico/Play preferences and my MacbookPro’s MIDI studio. I followed the posts and deleted the IAC driver, but still no input.


in your case it might be a good idea to start a new thread, as this one shows [SOLVED] in its title…