[SOLVED] Midi out of tempo

Hi Cubasis Team. I’m on an iPad 4, iOS 8.0.2. My midi files flutter in the tempo. I can see the notes are on even 8ths, but the playing is uneven. I’ve tried more files, same problem, even with small all-midi projects.
Kind regards, Sten

Forgot to write that I am using alesus io dock. And it might not have anything to do with this unit, but I tried to change hardware latency under the setup - audio, and my tempos are back to normal.
Regards, sten


this is also happening, while using just your ipad Audio without any external device?


Yes, it did. But after changing the hardware latency setting, the problem is solved, even though i’ve changed the setting back to what is was before.

Hi Stenfibaekjensen,

please provide an exact step by step description for us to reproduce the issue.
Feel free to send us MIDI files or projects (via WeTransfer link or similar) if helpful.

Furthermore please note that we’re equipped with the io dock also.



Sorry, I cannot reproduce the issue. It was introduced after my update to the latest version of Cubasis. What happened was:

  • I open a project, while the iPad is in I/O dock
  • Upon pressing play, the overall tempo of the MIDI events is uneven. I do not remember hearing problems in the audio tracks.
  • I try with som MIDI-only projects - same issue.
  • I try with the iPad disconnected from the Dock - same issue
  • I write the first post on this Thread
  • I go through all of the settings, to see if I can adjust memory, midi clock, latency or other parameters - nothing works, until I hit the “hardware latency setting”. On changing that, the unevenness disappears.
  • After that, all projects play fine regardless of the setting of the “hardware latency setting”.

And the %-quantizing works, which was my main concern in the first place.
If you wish, I can send you a project, but I cannot reproduce the error.


Good to hear all is up and running with Cubasis at your end, Sten.

Thanks for confirmation,