[solved] Missing handles on Select All automation

When you Select All on Automation Tracks, the selection rectangle disappears off the right-hand edge of the screen, along with its adjustment handles.

Accident or design? Or setup?


  1. Create an automation track with moves all along its length (there needn’t be a lot).

2. Manually select all the events on the line (i.e. with a drag).
3. Note that the selection shows as a box with handles all around - what I would call normal.

4. Select All Events on the track.
5. You will see the selection area disappears off the screen and you can’t use the right-hand handles.
6. Delete the first two-thirds of the track’s automation.
7. Repeat the select as in 4.
8. There is now a fair chance that you can’t even see the centre top scaling adjuster.

Can anyone confirm?


I can’t confirm. I got all points consistently selected with lasso and with ´select all´ option. I don’t know whats happening in your case.

May sound like an odd question but how closely do you have your Project Length trimmed to the track? I was thinking if you had plenty of white space beyond your events, then you would have room for this not to show up.

Thanks for taking the time, though.

Thanks to Cean for the post that set the marbles rolling around. It was the Project Length wot done it. Previously, the project had been longer and there was some remaining automation beyond the point I trimmed to.

Nice to know material survives the adjustment.

Ah, great you solved this. I didn’t think of this possibility.