[SOLVED] No flute present in setup mode

Ahem, in my copy of Dorico there is no flute present at all in the list of players (solo and group). Is there any possibility I might have cancelled it out of the list? Or is it perhaps a bug in the german version, since apparently no one else had this problem?


I only just realized when I switched my score from concert pitch to transposing and the treble flute switched to another key. Of course I wondered where the ordinary flute was, but on the other hand there were so many different flutes, I thought you called it treble as in ordinary (overly shrewd thinking, but you never know) and I did not know about the terminus treble flute in the english nomenclature.

Edit: Played around a bit… The woodwind group consists of 1 Klarinette in Bb, Oboe, Clarinet, Bassoon. Seems to be a translation issue then:

I must confess that I have never heard of this member of the flute family:

https://en.wikipedia.org/wiki/Treble_flute

so you are not alone in your confusion!

David

Another update. Just opened the Concert band template looking for how the brackets are implemented (in the US, they do it different). Flutes are replaced by “Klarinette in Bb” either. I even switched Doricos language to english (on a german Windows 7/64bit platform) and flutes are missing there as well.
Is there any possibility to unintentionally erase instruments/players?

For what it’s worth, I just tried a new project using the concert orchestra template and here is what I get :


As you can see, I do not have a flute, but two flutes :wink:

Hope this helps !

Thank you, Marc. I tried different kinds of approach, even the same as you, yet flutes are still missing. What kind of bug is that with my personal platform?
Windows 7/64, I admit, yet I refuse to use Windows 10 because of newly reported phone-home-functions and even installation of software by Microsoft on your personal machine!!!.
German language…
First project I tried: Importing of Music XML created by Neuratron or Sibelius, I do not remember exactly.

Flute did not reappear, and I use computers since over 30 years… (Yet I did not really dug deep in Dorico until now because of lack of time).

Don’t know if this applies to German version, but I know I was very surprised to find that instruments in Dorico were listed alphabetically rather than in score order. (If instruments were left in English alphabetical order and then translated to other languages, no telling where they might be in the list.)

Used xml file from Sibelius 8.3 of flute music which loads and plays correctly in Dorico.
I’m on Windows 10.

Just deinstalled Dorico and installed it back. Nothing changed, yet I found this entry in my list:


Probably some leftover from music xml import? All flute lines now read “Klarinette in B”, the flute as an instrument is replaced by that obscure B Clarinet. It has nothing to do with in what language I run dorico.

I thought the problem should have vanished after a new installation. Which files or registry entries do I have to erase manually to get rid of this wrong entry? Do you plan to release a Dorico removing tool for cases like this? Or shall I try to erase the whole halion package as well? I avoided that until now because it takes so much time.

Wait until Daniel responds to you, he is the one who knows. Maybe you could upload your zipped project in order for him to have a look, he is soooooo efficient !

Thanks Marc. Yes, I know…
For me it’s after midnight now - good night!

Same problem in the instruments list subsists after the update, so this is not the solution. Any suggestions?

Wolfram, if you start a new project and go to Engraving Options before you add any players, on the Language (Sprache) page, you can set the language for instrument names to German. You should then be able to find “Flöte” in the list of instruments when you add a player.

If you can’t, then you’ve somehow managed to edit the default flute instrument name. To resolve that, go to ~/Library/Application Support/Steinberg/Dorico in the Finder, and delete the file userLibrary.xml, which is where your overridden instrument name will have been saved.

I’ve already figured out the first approach, to no avail.

For other users with the same problem:
Deleting the userLibrary.xml file did the trick. Thank you! I first tried to edit the file, but it was locked, so I just deleted it. No harm done. Probably I managed the edit with importing a poor music xml file…

So this means I can write an own user library of instruments, right?

For windows users: It only works if you allow windows to show hidden folders (search for that on the net, preferably with ecosia first - sadly powered by bing, though :wink:). Go to C:\User (C:\Benutzer), choose your user name folder, than AppData/Roaming/Steinberg/Dorico and delete the userLibrary.xml.