[Solved] No mac/config folder in SDK

I am trying to get auwrapper from the latest SDK working with my plugin, but I can’t build my project. I built the auwrapper library as described, but when I try to build my project (as a Debug build for now), it can’t find the debug[.xconfig] file. I went to edit the [myproject]_debug.xconfig file to change the path to that file, but I can’t find any debug.xconfig file anywhere in the SDK. It used to be in base/mac/config, but there is no mac folder inside the base folder (either in the folder that came with the SDK or the generated folders from using the CMake app to generate my SDK Xcode projects). And a search of the entire SDK did not turn up that file. What am I missing?


That issue actually only gives me a warning, but following that warning I get a number of Link errors, starting with these:

Undefined symbols for architecture x86_64:
“typeinfo for Steinberg::FDynLibrary”, referenced from:
typeinfo for Steinberg::VST3DynLibrary in libauwrapper.a(auwrapper.o)
“Steinberg::String::assign(char const*, int, bool)”, referenced from:
CopyProcessPath(Steinberg::String&) in libauwrapper.a(auwrapper.o)
“Steinberg::FDynLibrary::FDynLibrary(char16_t const*, bool)”, referenced from:
Steinberg::VST3DynLibrary::VST3DynLibrary() in libauwrapper.a(auwrapper.o)
“vtable for Steinberg::ConstString”, referenced from:
Steinberg::ConstString::~ConstString() in libauwrapper.a(auwrapper.o)
NOTE: a missing vtable usually means the first non-inline virtual member function has no definition.
“Steinberg::ConstString::copyTo(char16_t*, unsigned int, int) const”, referenced from:
Steinberg::Vst::AUHostApplication::getName(char16_t*) in libauwrapper.a(auwrapper.o)

I’m not sure what is missing, but perhaps that missing config file is related? The paths that I see in the build logs are correct as far as I can tell, and I am able to include the auwrapper library that I built (in that path, which is also correctly specified in the build settings).

Ok, resolved. Had to add the base library to my project, which wasn’t required when using SDK 3.6.6, apparently. I was not able to generate the again example to compare against, but found that fdynlib was part of the base project, so I tried adding that, and it worked.