[SOLVED]: No more graphical glitches due to win border size!

Hi devs,
I normally don’t complain, since I love Cubase and am very grateful to have it as a working environment for my life as a musician, so: Thank you!
However, the issue depicted in my screenshot is very distracting and “un-pro” looking and apparently results just from users adjusting their window border widths. I know of course that this adjustment IS a “registry hack”, but still…
It should be possible to remove the garbage window content displayed around the edges in Cubase.

Thank you for your kind consideration,

Benji

EDIT: I reset the border size to default, and all is well. My apologies for polluting the forum and taking up valuable resources. Seriously. :blush:

Hi Mods,
I’d also very much like to continue an issues thread about this that I posted in, but it’s been moved to “SOLVED” and locked?
Please re-open!

Thanks,
Benji

Link?

http://www.steinberg.net/forums/viewtopic.php?f=232&t=77068

Steve, thx for double-checking!
B.

Hm… I wouldn’t be able move that thread. (it’s the subforum that’s locked, not the thread itself.) I hear what you’re saying, but registry hacks really can’t be accommodated. What a slippery slope that would be for developers! Why don’t you rename this topic to something more specific and continue here?

Fair enough… :neutral_face:
It’s just that this is likely the most common adjustment that power-users would make to their systems’ appearance, and I’d count Cubase users under “power-users” by default, actually…

Here’s to hoping that Microsoft re-introduces window border sizing as a mainstream feature again in Windows 10, and then Steinberg will be forced to fix it… :mrgreen:

Thx and all the best,
Benji :wink:

So the question is, does it work as intended in Windows 7 now?

Also, Windows 10 will have barely any borders at all, so it would be interesting to see what it looks like there.

Well there are some folks already using Windows 10, maybe one of them will post a screenshot. (you know who you are :wink: )

So here’s what happened: I adjusted the border size to 0 way back when building the machine, installed Cubase after that and Cubase behaved strangely ever since.
I just now experimented and changed it back to default…
And discovered that since I use Cubase (and most other programs) in fullscreen mode, there’s actually MORE space now and no window borders at all!
So: My bad for screwing around with that, and for the few times when there’s borders around my non-maximized windows, I’ll get used to those.

Case closed.

Take care and thanks for your patience! :smiley:
Benji

Thanks for reporting back.

I honestly don’t remember all my settings. Thought the border one would be safe.

Will check. Thans again.

Window border bug isn’t fixed yet in 8.0.20.

Changing the border is not a hack registry, though, you can change that value in the advanced configuration of Windows settings. It should work as intended.

In Windows 8.1 you can’t change the border width, unfortunately, only by manually editing the registry…
But I’d rather get used to the wider border for the few non-fullscreen windows that I use, than have SB accommodate Win7 and aforementioned hacks, and then maybe break something else in the process…
And Win10 will be here in a few weeks and supposedly change everything anyway.

B.

I was the one who reported this bug right after 8.0.10 came out. Should I just not bother next time?

http://www.steinberg.net/forums/viewtopic.php?f=232&t=77068&p=441431#p441431

In Windows 7, border width isn’t a registry hack. And the glitch isn’t just visual either, it causes the workspaces to restore at offset window positions.

djw,
I read you, I was/am in that thread as well…
My gut feeling is, that SB will wait for this to blow over with more peeps migrating to Win 8.1 and 10.
I myself made peace with the wider borders as a workaround to make Cubase work properly.
Strictly personal, so to speak… :wink:

B.

You’re probably right. What I personally hope is that they’re hard at work at rewriting the entire GUI and that the issues we have are because it’s a work in progress.