[SOLVED] Open with can't work well


I use Cubasis 1.82 of course.
I faced to a trouble of ‘Open with’ function in SHARE as follows…

selecting a file
Open with
Cubasis hung up/freeze
and endup a crash after a while
when I choose some 50MB over file.

On the other hand, no problem when smaller file is selected, i.e. 50 KB etc.

This problem didn’t occur before updating to ios8.02.

I need to transfer the audio file finished in Cubasis to another app.
Why it can’t work now though it worked well before ??


could you please provide a bit more information about your system? What ipad is this and any external gear connected?

Before means on iOS 7 or did you try out 8.0.1 as well?


Thanks much for your quick response.

I use iPad air with 64GB, and ‘before’ means ios7, now ios8.02.
I didn’t try ios8.0, 8.01 yet.

I use UR-44 of your’s steinberg, too, but this trouble happens without it, too.
And this problem didn’t happen before ios8.02 with or without UR-44.



More info as follows …

I thouht, first of all, maybe memory or storage has something like key, because bigger files surely made troubles but smaller one didn’t.

I used memory cleaner app, even did reboot ipad, three times rebooted.
But nothing got better at all, in the situation of running Cubasis only.

I have ever transfered 181MB via Open with function when ios7.x.x.

ipad air with 64GB
Storage status
used 34.6GB
usable 20.9GB

Cubasis 13.5GB
GarageBand 3.8GB

I don’t think any problem on the physical quantity of memory or storage.

Thanks again.

Hi again,

thanks for the extra info… I will investigate for you and hopefully come back with a solution soon!



I forgot to report these my experiences.

I have a app named AudioMastering ver2.8, maybe you know, too.

AudioMastering can send files as follows …

selecting a file
Share file
Open file in
selecting Cubasis

then Cubasis gets 181MB wav file via this gateway.

It was this file that had been sent by Cubasis via Open with function when ios7.x, but now Cubasis can’t do this again !

It seems that the same function of iOS is used by Cubasis’s “Open with” and by AudioMastering’s “Open file in”.

AudioMastering can run it, but Cubasis can’t do it under some conditions, influenced by size of file.

I hope these are useful info for you and you can find good resolution as soon as possible.


I have exactly the same problem with exactly the same setup:

Cubasis 1.8.2, iPad Air 64gb, iOS 8.0.2, UR44, various audio apps including Audio Mastering as “impian” mentioned above.

“Open In” function worked before iOS 8.0.2, other Share options like Audiocopy and Dropbox still work okay. I can share a Mixdown file using Dropbox BUT hate to do it because ADSL upload is of course much slower and it’s using up data allowance when I have to download it back into another app like Audio Mastering. I don’t like to use Audiocopy because it converts the WAV file to 44khz 16 bit.

Looks like iOS 8.0.2 is causing all kinds of problems…

Hope this information will help because I love using Cubasis!

Hi impian,

thanks for your report and repro.

We are able to reproduce the issue with mid-sized audio mixdown files (about 70 MB) and will evaluate the issue.

Sorry for the inconvenience.



Hi Lars,

Thanks for your efforts.
It is a good news to hear that the problem was reproduced, anyway.

I’m waiting a next better news :slight_smile:

The thing is, Cubasis is my favorite app!

The issue should be fixed within the next update.
We appreciate to hear Cubasis is your favourite app!



Ok, I comprehend the conclusion and expect the next update.

I appreciate your quick and appropriate supports.

Hope that a new fix won’t give birth to new unexpected side effects !

(Hi, microtoneaudio, thanks for you, too. I don’t like too using Dropbox and all to send files to another app in the same ipad, it’s awful as routine means, though acceptable as an emergency gateway)

We have been in exchange with Apple about the problem that appears to be a known issue for them (expected to be fixed with a further iOS 8 update).

Thanks, it’s nice to hear about the progress report after it.
It turned out to be kind of iOS problem ?

Just updated to iOS 8.1 - “Open With” still NOT WORKING with large files!!! Any further information you may be able to provide would be most welcome, as now my mobile workflow has come to a screeching halt. I know it must be an iOS problem because this function worked until iOS 8.0.2, so there’s something rotten at the core of Apple…

As mentioned above Apple is aware of the issue. Unfortunately we have no further information so far when the issue will be fixed by them.

Thank you for the information! I appreciate that you are trying to find solutions for these issues as quickly as possible, and it makes it hard when the operating system is causing the problem - Steinberg vs Apple! You are doing good work and I look forward to further evolution of this great app!

Thanks for your message. We are all sitting in the same boat… I’m confident Apple will come up with a fix sometime soon.

Hmm. Just updated to iOS 8.1.1 but this problem remains. I can understand that the fault most likely lies with Apple because it used to work before iOS 8.1, but I really hope something can be done, because it’s kind of pointless creating high quality uncompressed (large) audio files but then not being able to fine tune them in a dedicated mastering app. The workaround is to use Dropbox (unacceptably slow and a waste of internet download) or upload to computer and back into another app (defeats the purpose of going mobile and doing everything on an iPad). But I’m still looking forward to seeing this issue resolved - any further information is always most welcome! Best wishes :slight_smile:

  1. ‘Open with’ function of Cubasis can’t work well(no longer practical one) after iOS 8, though good before it.

  2. The same function of Mastering app has no problem before/after ios8.

I know it couldn’t be said that it is Cubasis that has some problems/bugs, though two facts mentioned above seemingly present it.

(e.g. Cubasis has some so strictly correct programs to protocols that iOS changes and it’s bug having deviations from the protocols could make Cubasis stuck. While the program of Mastering app has some play spaces that could make it go through the rough way and all.)

Anyway, there are two facts, one has been able to do a function we need, but another had lost this ability.

It seems very good for this ‘another’ to fix or adapt itself to this new situation somehow beyond expected in order to get the lost ability again for the sake of many users, putting aside which has the bug or not.

I’m afraid, but I think so now, because we have been left in the midst of inconvenience for relatively long time, how about you ?

Just upgraded to iOS 8.1.2 but “Open With” still not working with large files. This is a big problem because I cannot export high quality uncompressed files (i.e. WAV) to another app for further processing, nor can I store them to an external drive such as my WDCloud. One workaround is via the Cubasis WiFi Server, but that means I need to be near a computer - defeats the purpose of going mobile with an iPad. Another way is via upload to Dropbox and then download again, but that is very slow and a waste of Internet data allowance - if there is a WiFi connection to the Internet available in the first place. So at present it has become very difficult to do any pro quality work with anything external to Cubasis. Frustrating, because Open With was working really well before iOS 8.0.2! Any news about resolving this issue would be most welcome - but I fear we are at the mercy of Apple…