Solved: Playback not working in one specific file

The attached file was created in Dorico 2.2.20. I can’t get any sound from it. The keyboard keys in HSSE’s GUI move during playback, so it’s receiving MIDI. And the metronome click works.

I tried switching the playback template to silence, clicking Apply, and then re-selecting HSSE+Pro and clicking Apply, as Ulf suggested in a thread a while back, but that had no effect. I haven’t touched anything in the mixer.

I closed this file and opened a few other Dorico files and they played back without issue. So the playback engine appears to be fine.


Sonando (461 KB)

It certainly does sound here, although not on the slash regions (you probably have not recorded anything beneath it). What’s exactly what you were expecting? You know you can assign an instrument to the chord track and have this play, right? Piano and bass do play when they have explicit music written here.

Thanks for checking, Marc!

I’m expecting sound where there are notes in the score, and I’m getting silence.

You are correect - there are no notes beneath the slash regions.

I get the same result on my desktop and laptop computers.

On the laptop, I re-installed the 2.2.20 update, thinking perhaps there was a later build. But I already had the latest one. I also updated eLCC, though that seemed unnecessary. Neither of these helped.

This is strange… You don’t hear the click? I haven’t done anything to the file on my mac and I hear the click all the time, along with piano and bass when there’s something notated for them… If no sound at all, I’d think of a problem with the audio driver (maybe sample rate). Or there could be a problem with HALion install. Is this the only file that does behave like this on your system?

As I noted in my first post, I do hear the metronome click in the problem file. Without quitting Dorico, I tested a few other files on both machines and had no playback problems. So far, it appears to be an issue with this file only.

I sent the file to a friend running Dorico on a PC, and he got the same result: metronome click worked, but no piano or bass sound where there are notes in the score.

Only the click played back for me, but after reloading the Halion playback template it played back as expected.

I can’t see any obvious reason why that fixed it. The playback configuration looks the same before and after.

Note: this was on Windows not Mac, if that’s relevant.

I’ve tried this score and it’s not playing back correctly for me either. I think that something has got messed up for the audio engine data for HSSE, so I would suggest just do Apply Playback Template to get back to a working state.


When I tried changing the playback template via Preferences > Play > Default Playback template, nothing changed.

However, when I did it via the menu item Play > Playback Template… in Play mode, that fixed it.

Is there yet another way to do this?

Thanks everyone for the help!

Bob: changing the default template doesn’t change the file template, it just changes the… default.

If I recall correctly - which I might not - in the past someone said to change it in Preferences (I had it in some old notes).

Also, Paul’s post above said “do Apply Playback Template”, and “Apply” is only found in the Preferences window, not in the Playback Template dialog.

Strange thing is it did work flawlessly on my machine… Crazy, hu?
My default playback template is NotePerformer, so maybe that’s the reason why. It had to load HALion SSE as a playback instrument, because it was not already loaded. Just guessing here…

So is mine, and it didn’t work for me.

It’s computer software. It’s not supposed to be logical :slight_smile: