[Solved] Playback Options Not Saved With Score

When saving a score, my settings in the Play Tab - Playback Options are not retained. I have to reset these every time I open the score.

Previously I’m sure my settings were saved when saving my scores.

Does this happen for others?

Thanks.

For me it happens sometimes and not others. So far I can’t figure out the pattern. It does seem to be new behavior after the latest update, to the best of my observation.

If you haven’t changed the score then it won’t save the any changes to the playback settings. You have two choices:

  1. Edit the score and then save
  2. Save As…and overwrite the existing score. This will also save any changes to the playback settings.

The issue is that currently Dorico doesn’t’ know when the playback settings have been edited.

Hello samreed,

Thanks for replying.

Well, after several attempts I finally managed to get Dorico to save my playback settings. To my knowledge, I did nothing differently to making an edit to my score, resetting my playback then selecting to “Save as” and naming my project.

I’ll try this with a new test score to see if the problem persists and will post back.

The thing is I have been making playback changes and saving my scores without problems since I started with Dorico. The problems I have now have only started since this latest update.

I tried both things you mentioned without success. After numerous attempts I have now managed to save my settings. As samreed mentioned in his/her post a similar thing is happening there and there appears to be no discernable pattern to this behaviour.

I’ll keep keep testing and will post back if I find anything.

Here is an old thread on this topic.

https://www.steinberg.net/forums/viewtopic.php?f=246&t=118001

Hello dbudde,

Thanks for the link and I made a note of the saving process advised.

Unfortunately, for me, it still hasn’t resolved retaining the playback settings.

Here’s what I tried:

  1. Opened the score and reset my playback options.
  2. Made an edit to the score.
  3. Selected “Save As” as suggested in your link and, to be sure, selected a new location to save to.
  4. I then reopened the score.

Result:
My edit to the score was retained but my playback settings were not.

I also tried reversing 1. and 2. above. Made a score edit first, then reset playback but the result was the same.

Not sure why it isn’t working for you. What playback devices are you using? This has always worked for me.

By the way, you can do either of the items I mentioned, not necessarily both of them together, although that should also work.

I can’t reproduce this problem, Michael. If you open your score, open Playback Options, change e.g. the dynamic power curve from the default of 2.5 to (say) 3.0, then tab away from the field to make sure Dorico knows it has changed, you’ll see that the Apply button becomes enabled: click Apply, and Close. Contrary to what Dave says above, this will make the score dirty, i.e. able to be saved, so save it, close it, and reopen it again. Open the dialog again: the dynamic curve power will still be set to 3.0 (or whatever you set it to at the outset of this process).

My mistake, I thought he was talking about playback devices, not playback options.

Hello Daniel,
Thank you for replying; it’s very much appreciated.

I’m pleased that my issue is unexpected and that it should all be working ok. I did follow your saving suggestions but the problem for me persists so it is obviously something specific on my system here (Windows 10 64 bit system).

I tried unininstalling followed by a clean install but still the same thing happens.

I’m sure it will resolve itself sometime as mysteriously as it appeared.

Best wishes.

Can you attach a project here and provide details of which setting(s) you’re trying to change, so we can have a go at reproducing the issue in-house?

Hello Daniel,

Thank you for your suggestion to have a go at reproducing the issue.

I was preparing to attach a project and just happened to set “Layout Options > Vertical Spacing > Inter-System Gap” and now my “Play-Tab > Playback Options” are now working.

I’m sure this is just a coincidence of some kind but I’m pleased Playback Options are now working for me.

Thanks again and best wishes.