[SOLVED] Polyphonic Aftertouch not being recorded?

But It will record Channel Aftertouch. Cubasis 2.6. with CME XKey Air. Doesn’t 2.6 support Polyphonic Aftertouch? Thanks!

Tried the Alchemy synth in GarageBand for iOS and both Channel and Poly Aftertouch is recorded and heard! In Cubasis 2.6 only Channel is recorded, no Poly. Even with it receiving and recording Channel Aftertouch I can’t hear is responding to the keys.

I’m having an amazing Poly Aftertouch experience in GarageBand for iOS with the XKey Air. Why is this not possible with Cubasis but is on GB???

This topic seems to be continually ignored or answered very vague.

I’ve read that Cubasis will respond and record Poly Aftertouch but only if a third party plug-in is capable of Poly Aftertouch. This was mentioned by Lars in a previous post. He states that Poly Aftertouch will record once a compatible plug-in is used. So I loaded up Kauldron Synth and made sure my controller was sending Poly Aftertouch. Went through every single patch and no Aftertouch recoded in the MIDI editor. Switched my controller to Channel Aftertouch and Aftertouch shows up in the editor. But no audible evidence. Now even though the synth does accept Aftertouch, maybe they have no patches to take advantage of Aftertouch. I don’t know. I will try some other synths.

Regardless, Lars mentioned only Poly Aftertouch would be recorded with a third party plug in capable. But even if I just use the Micrologue synth in Cubasis, which is NOT Aftertouch compatible my Channel Aftertouch still gets recorded regardless. So it blows that theory out of the water.

If Cubasis is truely Poly Aftertouch compatible, then Poly, not just Channel Aftertouch data, should be recorded. I don’t see it being supported at all considering it’s ignoring the Poly Aftertouch data completely. :confused:

I’ll see if I can call Steinberg regarding this. I’m not getting anywhere here, just self analyzing my situation. :weary:

Hi desertpeaks,

Cubasis 2.6 records and plays back polyphonic aftertouch, regardless of the plug-in. However, you will only hear something if the AU plug-in or the MIDI output target responds to poly aftertouch. There are 2 limitations:

  1. The internal Cubasis instruments (Micrologue, Microsonic…) don’t respond to poly or channel aftertouch.
  2. The MIDI editor doesn’t display recorded poly aftertouch data, it only shows channel aftertouch when you select “Aftertouch” from the list.

Here is how to verify that poly aftertouch works with Cubasis and Kauldron:

  1. Add a MIDI track and record poly aftertouch with it. We used the “Roli Noise Melody” AU instrument to record poly aftertouch data and a few notes.
  2. Double tap the recorded MIDI event and use the MIDI editor to delete all pitch-bend and (channel) aftertouch data. This is just to verify that poly aftertouch is really the source of what we’re going to hear.
  3. Assign the Kauldron Audio Unit as instrument to the track.
  4. Select the Wild Hops preset (under Keyboards)
  5. In Kauldron’s MOD menu, set the first target to “Pitch +12”, mod to “LFO 1” at 100, and control to “Aftertouch” at 100.
  6. Start playback. You will hear heavy pitch-bend that is triggered by poly aftertouch (since pitch-bend and channel aftertouch data was erased from the MIDI event in step 2).



Thank you so much for your detailed response. I apologize, I meant to reply last night as I think we are on the same page! :slightly_smiling_face: Meaning, yesterday I performed basically exactly how you instructed. However, I did this the other day too. Within Kauldron I altered and saved 2 patches in the exact manor you mention. I still got inconsistent playback of recorded notes whether they were regular channel Aftertouch or Poly. I realized that Cubasis can indeed record and play it back, both types. Also, I realized too that only channel Aftertouch is displayed in the editor. What fixed everything in the end was uninstalling Cubasis and reinstalling it. Now everything is perfect! :grin: Now Kauldron responds correctly as the notes and data were correct all along. It was something with either Kauldron and it’s MIDI implementation or just a glitch in my Cubasis installation. Regardless, everything works great now.

Thank you Lars for your time. I apologize if I spoke out of place, I guess it was just an isolated incident. Even phone support was stumped to why it was happening. I’ve been using Cubase since 2002 and Cubasis for a few years and never experienced that before.

Thank you again!

Hi desertpeaks,

Thanks for your message and update. Glad to hear things work as expected!

In general, the Steinberg forums are unsupported user forums. Nevertheless, we do our best to quickly help all Cubasis users on a constant level, whenever possible. In your case, I had to check back and exchange with our engineering first, to provide you with a decent feedback. So depending on the individual case and/or workload of our small team, it sometimes can take a moment before we reply.



Absolutely understood. I apologize for my frustration. Thank you so much for your time and help! Have a great day! :slightly_smiling_face: