(SOLVED) Possible bug with Automation / Snap to grid?

If I am editing some automation points in the arrange page, I often hold down Control so I can drag a point horizontally and reposition it to a bar/beat (with quantise snap turned on). This was fine in C8 but it’s a little different in C8.5.

In C8.5, whilst I am holding the Control key, the automation does not snap to the grid. I have to hold Ctrl, start the mouse move and then release Ctrl in order for it to snap to grid. Seems a bit awkward. Seems like a bug, unless there is some other reason for this change that I’m missing? Can anyone confirm or explain this?

Why hold ctrl?
I thought that was for a free-move (temporary defeat of snap to grid)
With snap to grid turned on can’t you just select with the arrow tool and then click-hold drag an automation point to move with snapping to grid? That works for me on 8.5 and snaps to bars beats or quantize value as I choose on the menu bar.

Why hold Ctrl? -because I want to move the automation point along the timeline without changing the value. With automation in C8, holding Control means that the automation point can only be moved horizontally or vertically.

Let’s say I’ve written some automation with the fader. The last point of automation is not quite snapped to the bar. In C8, I just hold CTRL, grab it with the mouse and drag it to snap on the bar, and I can be sure that the value will not change, ONLY the position on the timeline. Nice and quick and something I do all the time.

Ahhh yes… My misunderstanding…
Tried it and I would agree that a value locked snap to grid movement should be default with ctrl.
Then a modifier, either shift or alt could be used to defeat snapping but neither work in 8.5!

Did you post this to issues forum ?

I think what it is, is if you hold CTRL before click/drag, it will be constrained vertically or horizontally. If you start clicking/dragging and THEN press CTRL, it will override the snap.
But I may be wrong, I’m not in the studio right now…

I’ll try later.

Just investigated a bit further and actually ‘Bug’ is the wrong word (just edited the thread title). Here’s the difference that I’m seeing and I guess once you get used to it, it will be an improvement

In C8, you hold CTRL, then click, and dragging is constrained vertically/horizontally.

In C8.5, you hold control, then click, THEN LET GO OF CONTROL, and dragging is constrained horizontally/vertically. If you carry on holding CTRL, then snap is temporarily disabled. So actually, additional functionality has been added.

1 Like

Yes, that’s working that way for me too.
Thanks for the tool tip!