[SOLVED] Routing multiple MIDI sequences to separate tracks using one MIDI sequencer? (Blocking/Isolating MIDI channels)

Hi Cubase community.

I’m having an issue with trying to play and midi record dual midi sequences, a synth pattern and a drum pattern simultaneously on two separate instrument tracks using one hardware sequencer via USB. In this case, I’ll be using a LinnStrument.

In order to achieve this, LinnStrument needs to send one midi sequence to midi channel 1 and the other sequence to midi channel 16. As shown here: (LinnStrument Step Sequencer: https://youtu.be/bhy_Wx2PWVw?t=912).
Now the strange thing is that when I try to play a drum pattern simultaneously with a synth pattern, both patterns go to both VST instruments (with both tracks highlight/selected with shift+left click), not one pattern per VSTI as I would like.

I made sure to test the problem with Midi Monitor. The strange thing is that when ever I change the midi channel via the Inspector, Midi Monitor says it’s receiving the currently assigned midi channel. So if in the inspector’s midi channel select’s drop down menu I select midi ch. 1, Midi Monitor says it’s ch. 1. If I select midi ch. 2, Midi Monitor says it’s ch. 2, etc. The only time when Midi Monitor says the correct incoming midi channel from the LinnStrument is when receive “Any” is enabled, Then Midi Monitor says channel 1 or 16.

I can block entire midi controllers via the inspector’s “Input Routing” menu. I can make the LinnStrument only able to record to specific instrument tracks like to synths and I can make the Akai MPK mini only able to record to a groove agent instrument track. I made sure it wasn’t just the LinnStrument and the same issue with not being able to block unwanted midi channels via the inspector happens with the Akai MPK mini. So with “Any” select in the inspector’s midi channel select’s drop down menu, Midi Monitor says it’s receiving midi channel 1 (which is the MPK’s default channel). With midi channel 2 selected, Midi Monitor says channel 2 is received, ch.9 = ch.9, etc. I can only block the MPK via the Input Routing menu in the inspector.

The only VST I’ve found so far that I can block specific incoming midi channels is HALion Sonic SE: 2. If in HALion Sonic SE: 2, I go to the “MIDI” tab in the “Edit Instrument” screen and go to the “channel selection” drop down menu of the “key range” screen and I select the desired midi channel, every other midi channel will be ignored. Every other VST including, Groove Agent, Steven Slate Drums 5, Retrologue 2, Synthmaster 2.9 and Synthmaster One accepts all incoming midi data, no matter the restrictions I put on the inspector’s midi channel select’s drop down menu.

Is there any way around this issue? Or is simultaneously recording two different midi patterns on two separate instrument tracks from a single midi controller a feature that most people don’t need?
I’d appreciate any help given.

Thanks and have a great day.


All MIDI/Instrument tracks of Cubase are always receiving MIDI data on all MIDI Channels.

If you want to filter some MIDI Channels out on a MIDI Track, use MID Input Transformer. This feature is definitely not part of Cubase Elements. Maybe it’s Cubase Pro only, I’m not 100% sure about Cubase Artist.

Hi, Thanks for responding. Thought I’d never get an answer.

As suggested, I used MIDI Input Transformer to block the unwanted midi channels and was successfully able to block midi channel 1 completely, to the point where it doesn’t even show up in midi monitor.
What I did was create a new Filter Target and selected Channel, Set Condition to Equal and Parameter 1 to 1.
Doing this and setting the Inspector’s midi channel to “Any”, killed all unwanted midi from midi channel 1 to the drum VST.

Repeating the above step for channel 16 (Filter Target set to Channel, Condition set to Equal and Parameter 1 set to 16.) unfortunately does not eliminate unwanted midi notes from channel 16 (to isolate the main sequence, ch. 1, from the drum sequence, ch. 16).

I’m able to prevent midi channel 16’s (drum) notes from triggering VSTs by setting the Inspector’s midi channel to “Any” and (if available) setting the VST’s midi channel to 1. But by doing this, the VST is still receiving midi notes from channel 16, they just aren’t audible. The unwanted channel still appears in midi monitor.

So, I’m able to completely block midi channel 1 but not midi channel 16 with Midi Input Transformer. I’m not familiar with Midi Transformer so I’m not quite sure how to block midi channel 16. I’d really appreciate any further instructions you can give me.

Again, Thanks a lot for the assistance.


I expect you did this in the Input Transformer Module 2. Did you enable the module?

Could you attach a screenshot of the Input Transformer settings?

You could also do it in one Module (see attached screenshot):
Channel | Equal | 1 | Or
Channel | Equal | 16


Function: Filter


I’ve figured out what the issue was. My version of MIDI Transformer looks different than yours (I’m assuming yours is the newer version) but at the very bottom of the MIDI Transformer it has a parameter called “Function” with options “Delete”, “Transfer”, “Insert” and “Insert Exclusive”. Upon loading the MIDI Transformer, “Function” defaults to “Transfer”. So all I had to do was set Function to “Delete” and everything works perfectly. No more pesky unwanted midi channels where they don’t belong. :slight_smile:

I’m not too sure if your other method (pasted below) is possible with my version of the MIDI Transformer (I’m using Cubase Pro version 8.5.30 64-bit) as my version does not have “Filter” as an option. I’ve attached a screenshot.
Channel | Equal | 1 | Or
Channel | Equal | 16


Function: Filter

You seem like quite the Cubase forum veteran judging by your post count and Elder status. :slight_smile:
Any suggestions as to what I should title this topic so future forum members can easily find this solution?


You are not using Input Transformer but you are using MIDI Insert Transformer. So you don’t process (filter) the data on the input already and you record the data unprocessed.

You process the data before the output.

Is this what you want to do or do you want to record it processed already?

I couldn’t for the life of me find the MIDI Input Transformer you were talking about, So I googled it. :slight_smile:

I was very pleasantly surprised to find an official Cubase tutorial on YouTube showing the capabilities of the MIDI Input Transformer.
The Input Transformer was right under my nose the entire time in the Inspector panel, right under the edit channel settings “e” icon and to the right of the read/write automation “R/W” icons. :slight_smile:

Link: How to Use the Input Transformer in Cubase | Q&A with Greg Ondo: https://youtu.be/NMQGUJT4KCs?t=280
It’s time stamped but I recommend watching the entire video.

As a very nice bonus, I’m now able to use my LinnStrument’s sustain pedal to trigger midi note 36, aka MIDI drum kick’s (any note is possible) . It’s just a simple Roland “on/off” non-latch sustain pedal so the sensitivity/responsiveness of an actual electronic drum set’s kick drum tower isn’t there but it does the job and it’s substantially quieter than e-kick drum towers.

I would not have known which key-words to search if it wasn’t for your generous help, Martin.
Thanks a million for the response and for guiding me towards the Input Transformer’s light. Take care of yourself. :slight_smile:

The Goal:
Play simultaneous MIDI sequences from one MIDI controller (in my case, a LinnStrument), With absolute control over the MIDI pattern’s destination. :sunglasses:

The Problem:
Playing dual MIDI sequences on separate MIDI channels defaults it’s MIDI note’s/pattern’s routing to all “record enabled” tracks.
This may not be wanted if one MIDI pattern is meant to be exclusively routed to drums. :cry:

The Solution:
Enable the “MIDI Input Transformer” found in the Inspector panel. It’s icon is a bending arrow pointing right. It’s located above the freeze instrument channel’s snowflake icon and below the edit channel setting’s “e” icon.
Choose “Local” in the Input Transformer’s drop-down menu and select which midi channel you’d like to give exclusive rights to your currently selected track via “Channel Filtering” in the Input Transformer’s preset menu.
This will create a new Filter Target with these values: Filter Target = Channel | Condition = Unequal | Parameter 1 = 1 (or your desired midi channel. In my case, it’s set to 1 for the first pattern and to 16 for the second midi pattern, on a separate track.) | Function = Filter.
Enable the module via the blue power icon at the top of the Input Transformer.
Enjoy. :smiley:

How to Use the Input Transformer in Cubase | Q&A with Greg Ondo: https://youtu.be/NMQGUJT4KCs?t=280
Timestamped to the MIDI channel filtering portion.

Praise be given to Cubase forum Elder, Martin.Jirsak, for his vast Cubase knowledge. And for taking the time to educate a new forum member. :smiley:
Also, Credit goes to the master of Cubase tutorial disaster, Greg Ondo, for his amazing devotion to teaching “The Ways of the Cubase”. :laughing:
Obligatory credit also goes to: The Steinberg engineering Gods, The engineers behind MIDI, Electricity, The internet, Farmers (for feeding us all), The Earth, The Sun and every last molecule in the galaxy responsible for Music. :sunglasses: