[SOLVED] Snap To only snapping to 1, 2 etc

New here and new to Cubase Elements 8. Absolutely love it. Just trying to decide if it’s the platform for me before jumping up to Pro.

Discovered Media Bay, and started creating tracks by double clicking on sounds (wav files) in Media Bay. Then I’d drag and drop the file, and start editing. Mostly Kik, Snare and Hats.

Worked great for Project #1. Created Project #2, opened Media Bay, double clicked on a file - new track popped up called

FC01_R&B_1_Snare2_RT

Back to Media Bay and dragged and dropped the sound into the track. No problem. It landed at the beginning of Bar 1.

Tried to Alt–> drag that item to another place in the bar, and my problems started. It wouldn’t drop in, just snapped back to 1. So I decided to try and Copy–>Paste it. I copied it and tried to put my vertical navigation line (the big vertical line that runs top to bottom which we use to navigate in the project window) to the 3rd beat of the bar.

And the vertical line won’t rest at the 3rd beat! It snapped back to 1!

Okay, so somehow, Cubase has configured itself to Snap To only whole numbers or only the first beat of the bar, and furthermore I can only drag events to that spot. 45 minutes and lots of searches later, can’t figure it out. I can make this stop by choosing Snap Type as Events or turning Snap To off, but of course that’s not what I want. I want it to Snap to the neartes 1/16 or whatever I’ve chosen. Manual says something about ‘Grid Quanitize’ possibly causing this but I am not set to that. I didn’t change anything… or did I? What I find with Cubase is that when something looks like a glitch, 99% of the time it’s not a glitch. Instead, Cubase has reconfigured itself to behave in a certain way. The question is, what causes this? I guess it’s probably sloppy mouse technique or sloppy Ctrl–>xx technique.

My Snap To is on, Tried Snap To Zero Crossing both on and off, Snap Type is Grid

Can anyone help?

I figured out that somehow, the ‘beat’ setting had switched to ‘bars’ and this was causing the behaviour. The question remains - how did this get switched? I’m experiencing this quite a bit and again, I’m sure I’m causing it but don’t really know how. I guess I’ll just try to be very accurate with mouse events and key commands.