[Solved ... sort of] Resolve Missing Files Problem

I have searched this forum and found no resolution, so I’m posting this question.

I had a directory called Untitled 07 (or some such). It contained two empty subdirectories, Audio and Images. Nothing else. I deleted the parent directory.

From that point on, every project I tried to open gave me the “Resolve Missing Files” dialog. Nothing I could do seemed to correct it. I restored the Untitled 07 directory and contents from the trash bin (Win 7, Cubase 7.5) and the dialog went away. But the file cited as missing was not in the restored directory in the first place. In the second place, I could find no project that referenced the missing file. I’m quite new to Cubase, so I have very few projects that have any significance, so looking at each for a reference to the missing file was easy - there were none.

Now, I’ve gotten the annoying dialog to stop showing on each project open, so that’s progress. But it makes no sense. Why was I seeing this warning in the first place? Also, should the “Restore Missing Files” dialog not have some option to say “delete reference, this file is not important” or something to that effect? I spend (wasted) a lot of time trying to sort out this non-problem that appeared to be a valid problem.

Thanks for any direction on this problem.

Mmmmmm! This is an issue that has puzzled me quite a bit as on a number of occasions I have created a new track forgetting to name the project. On one occasion I it had defaulted to the C drive. I was recording parts that did not appear in the Audio and Image folders. I then realised that I had no idea where the parts were so looked in the pool to discover their location. I think they were in a previous project. I backed up the new project, then deleted all unused files in the old project. However I kept getting missing files. Actually I have a number of projects with this issue where I have no idea hoe to get rid of the Missing Files dialog.

First of all let me reiterate that I got the warning dialog on every single project I opened, including new ones created from a more or less empty template (control room only stuff preset). It was not just some projects, and it always named the same “missing” file.

Also I forgot to mention that I could at no time find the Remove Missing Files menu option other than disabled. Had I had the chance, I would have tried that to see if it corrected the problem. But the command was always disabled.

By the way - is this the best place to post something like this? I’m not very experienced with the Steinberg forums. Would it have been better to post in Issues? Thanks for any guidance.

Through all of this are you actually missing any audio files, or is cubase just citing as you say?

The pool might be the key. Open pool and right click in it, select remove unused media, not to trash though.

Save , and reopen and if you get missing file message again, choose locate and then set the new path.

The original path you deleted was probably still showing in the pool as the current path therefore cubase was trying to phone home but with the wrong path. With Cubase if you have audio video files and then change the path to them by deleting folders it won’t be able to see them anymore.

Check the Pool. If there is an unused audio file lurking about there, it can cause these kinds of problems. I’s easy to miss and, at least, worth checking.

Thanks for the suggestions. I’ll give it a try and report back if anything interesting comes of it.

No joy. I opened the pool and for the first time saw the remove missing files command enabled. So I tried it but nothing changed.

So, I guess the important question is this: how does one safely delete a project? Clearly just zapping the directory is bad news because you end up with the missing file dialog. So how do you do it? There does not seem to be a “delete project” command that I’ve been able to find. Thanks for any enlightenment.

Did you remember to empty the trash in the Pool? It works just as in your OS. You must empty it to truly remove the (missing) files from the Pool (project).

Of cause there is no “delete project” command. Deleting a project isn’t done from within Cubase. Close the project and delete the project folder, just like you delete any other file or folder.

If you post your systemspecs in your signature, you’ll make it easier for us to help you.

I did not do the empty (at least after I did the remove missing files. Will try and report back.

Close the project and delete the project folder, just like you delete any other file or folder.

Well, that’s what got me into this mess in the first place. :slight_smile:

I will put system specs into my sig - thanks for the suggestion.

when this mess started, did the new project have the same name? I think a new name in a different top folder name, might help, so hard drive V now has a new folder called project 2…

I honestly don’t remember. I’m a fairly new Cubase user and I had all kinds of squirrelly experimental projects with “Untitled” in the project name. My intent was to get rid of the garbage, but I can’t recall the purpose of many of those projects nor their history.

Going forward,

  1. Always start a new project by creating a new, properly named folder for the song.

  2. When importing audio, use the setting “copy files” to directory or whatever it says.

If you do the first one above these issues should be a thing of the past.

Sounds like you have audio files in your “template” file that shouldn’t be there.

Yes I think using untitled as name each time is causing cubase to point to old. Locations, Chang name and you should be good

Did you omit something at installation? Maybe made a mistake doing something else entirely and didn’t think it mattered?
Sounds like your templates (and Projects?) are missing certain files on loading. This is almost always due to the Installer app or the user. Rarely, could be defragmentation issues.
I’d reinstall Cubase and start again but try to remember every step (and if you did something when you installed last time don’t do it this time).
And it’s very important to defrag and clean up a Windows machine after installation.

Duh! didn’t read slowly enough. “Untitled” files might just simply need naming. If you’re still getting problems then consider a reinstall just in case.

Although there was this:

First of all let me reiterate that I got the warning dialog on every single project I opened, including new ones created from a more or less > empty template > (control room only stuff preset). It was not just some projects, and it always named the > same “missing” file> .

So I’ll go with my original advice.
What was the name of the SAME “missing file”?
Was it a file you created or one from the templates? I sometimes find that the templates try and find files, samples etc. made by the template creator I presume that they are either not present in my Cubase installation (due to me rejigging something) or were stored at the creation point with a different destination.
(my guess)
If it picks up all your relevant files and you have a “do not show this again” button you could ignore them if you’re pretty sure what the cause is.

Yes, this is something I’ve learned since as I’ve gotten to know Cubase a little better.

It seems to me that the dialog for creating a new project could be a little more user friendly in this fashion. It should give you the option of naming both the directory (if a new one is to be used) and the project name in the same dialog. I’ve since learned how to make sure I get properly named directories, but this is probably something newbies run into all the time. In any case, very good advice - thanks.

Seems to me that cure is worse than the disease. It’s way easier to leave an empty directory sitting there. For whatever reason, the warning dialog goes away, even though that directory does not contain the file cited as missing.

In any case, I seriously doubt this is an installation issue. The problem only started happening after I deleted a number of unwanted projects (all in directories name Untitled-something because I didn’t know better at the time). As to defragging, that would make absolutely zero difference other than maybe allowing Cubase to start a bit faster.

Also, OT, but I have wanted to add my system information to a signature, but I cannot find where to do that. Can anybody point me to where I do that? Thanks in advance if you can.

Once you’re logged in, go to ‘User Control Panel’ at top left of the page, then click ‘Profile’ tab, then ‘Edit signature’.
Type whatever you want in the empty field, hit ‘Submit’ and that’s it.


Thanks. Seems to have worked. :slight_smile:

I had exactly this issue due to creating and using a template I created from a previous project where I had removed all the tracks from the project window but neglected to do the same for the pool. As such every new project complained about missing files. My first question would be does this happen when you create a new project from one of the stock cubase templates that you havent updated. If that works I’d guess its the same issue I had.

I tried that and, as you speculated, I was able to close and reopen the project based on the stock template cleanly. No warnings about a missing file.

However, then I made a real breakthrough (probably not related to the previous step, but who knows?).

I opened a project that had a legitimate missing file. For this project, I had previously exported a mix to a wave file on the desktop. I then moved that file elsewhere. After that, when I opened the project, this time I got a message about two missing files: the one legitimately missing and the phantom missing file. I opened the pool and they were both there, actual under Audio and phantom under Trash. Ah, so this is how the pool is supposed to work! Previously the pool showed no files present and executing “remove missing files” had no effect be the pool evidently thought it was empty, even though Cubase had flagged a file as missing upon project open.

With both files in the pool, I executed “remove missing files” and this time it worked. Glory be!

So, a workaround seems to be the following. If you have a dialog upon project startup sating there’s a missing file but that file is not listed in the pool do the following. Create a real missing file in whatever way is most convenient. Open the project and go to the pool. The phantom file will hopefully show up and a “remove missing files” command should do the trick.