SOLVED: Still no Audio Playback

I’ve still a problem with the audio-playback. No sound at all. :cry:
The last thing, I’ve tried, was the “cleanup_prefs_and_engine.bat”.
It did something, now I have the possibility to change settings auf the device (this wasn’t before).
I’ve also tried the suggestion, to start a new project only with piano - still no sound.
I’ve attached a few screenshots, perhaps they are helpful to solve my problem.
I would be very glad, to get a solution for my problem.
Many thanks!

After you have changed the device to ASIO4All, close Dorico and then start it again. There is a bug (which will be fixed in the next update) where changing the device didn’t have an effect until the application was restarted.

Moin Johannes,

also, from the second screenshot (whole_playback_screen) I can see that actually no HALion instance is loaded. So even with a correct driver, this will not play out anything. Go to Play Mode, then choose from the menu Play > Apply Default Playback Template (it’s the last entry in that menu). That will load HALion and an appropriate sound.



still no success.

I’ve tried nearly everything, but it doesn’t work at all.

I’ve written a few scores for piano.

Tried the suggestion “Apply Default Playback Template” … no success …

What makes me a little bit wonder is, that under VST-Instrumente, I dont see anything (screen_right.jpg).

I’ve read in the forum, that there should be a folder named “VSTAudioEngine_64”, I dont have this one. Could this cause the problems I have?

I think, the settings in asio4all should also be ok.

Many thanks for help!


If you open Windows Explorer and type %APPDATA%\Steinberg\ into the address bar, that should take you to the folder in which the VSTAudioEngine_64 folder is located.

Hi Daniel,

thank you, I’ve found the folder.

But still no sound … :cry:

And no VST-Instrumente at the right part of the screen …

Do you have an idea, how I could get sound? :question:

Thank you!


The important thing we need to know is whether the audio engine has crashed, because if it has then this will explain why you have no sound. When you start Dorico and then load a score and press Play then check the Task Manager to see if the process Vstaudioengine.exe is still running. If it isn’t then we’ll need to look at the crash logs. See the FAQ to find out how to enable these.

I have done this now and Vstaudioengine.exe is still running.

Can you manually load HALion Sonic SE by choosing it in the menu from the VST Instruments panel in Play mode? If so, and you show its window, can you then manually load a sound into the first channel, e.g. the Yamaha piano sound? If so, when you then click on the little piano keyboard at the bottom of the HALion window, do you hear sound?

That’s not possible, when I try it, I only see this “—” in the pulldown-menu.

Is it possible that you somehow chose not to install the HALion plug-in and the content when you first installed Dorico? Perhaps you should try running the installer again.

I have followed all of the steps above. I can get sound in a New Project with a Piano instrument added, but when I reopen an old project I get no sound, even after reloading from the default playback template. Exporting to MusicXML and importing it into a new project did not help.

:smiley: :smiley: :smiley: :smiley:
Hello Daniel,


I started the installer again and was suprised, that a few points of the setup haven’t been installed at the first time I made the setup.
I remember, that there were problems at the first time I’ve made the setup. Now everything has been installed without problems and the HALion plug-in also has been installed.

I’m very happy, to be able to listen to the projects I’ve written now!

Many thanks!!!


You can go back to your first post and change the subject line to “SOLVED: Still no Audio Playback”. That will let others know that

  • the problem has been solved and the thread is finished
  • They can check this thread to see if the solution will help them with a similar problem

Incidentally, your thread was really well named in a way that can help others with similar difficulties.