[SOLVED]Text avoidance - placement of glyphs makes them jump

I’m currently working on the guitar part to a pop chart. At the beginning of the bar the guitarist is required to slide up to the start of two notes (D and F). Currently these types of glyphs are not supported natively in Dorico (yet) so I have needed to use text events to paste in the appropriate (slide) glyphs, copied from the Smufl site. I need two occurrences of the slide – one for each note. They are acting like magnets with the same polarity; when I attempt to place them directly underneath each other and they get too close, one would jump (either above or below) the stave making it impossible to align them correctly.

I read in the manual that “Text is automatically positioned to ensure that it does not collide with other objects”. It seems Dorico is true to its word and therefore I am stuck. There seems to be no override to this (there may be one but I’ve been unable to find it)

In Setup I have disabled the ‘Automatic resolve collisions between adjacent staves and systems’ in desperation. It has no effect (I’m clutching at straws now).

Is there a solution?



double slide to notes.jpg

In Dorico Pro 2, you can disable collision avoidance on individual text items from the properties panel in Engrave mode. You can also turn it off completely in Engraving options > Text


Thank you! I did notice in the properties that I could ‘Avoid collionsions’ which is exactly what I didn’t want but your solution to use the text option in Engrave mode did the trick!

NB. I wonder why that particular option isn’t included in the properties - there seems to be room.

Anyway thanks again.

For what it’s worth, you should be able to turn off ‘avoid collisions’ locally if you switch on the property but leave the box unticked.