Solved: Track changes when I select the Range Tool ?!

Here’s my problem, if someone would like to try replicating it:

  • click a track (A) and select a range
  • choose the ‘select tool’
  • click a different track (B)
  • choose the ‘range tool’

When I do the above, as soon as I select the range tool, the selected track jumps back to track (A) where the last range selection was made. It’s driving me nuts!

Now I don’t use the range tool all that often, but what I do always like to use is the macro: tool 2 -> previous tool, which helps keep the ‘selection tool’ on ‘normal sizing’.

I ended up getting around this by changing the macro to: color tool -> next tool, but just realized today that there is no color tool in the Key Editor, so the macro doesn’t work.

\

  1. Is there any way to disable the ‘switching to the last track with a range selection’ when choosing the range tool?
  2. Is there a macro that helps keep the select tool on ‘normal sizing’ that would be useful in both the project window and the key editor that doesn’t involve the range tool!

(this is so damn convoluted for something so simple!) I just don’t want that cycle through the select tool!

Ok, partially solved, but I’ll leave it up in case it helps others or someone has a better solution.

Disabling ‘Preferences -> Editing -> Track selection follows event selection’ was the way to stop the track jumping. So I can go back to the original macro that involves ‘tool 2 -> previous tool’.

I’ll probably assign a key command to toggle that option though as it’s useful.

re 2]

yes, i dislike it too.

here’s a macro that prevents the cycling that i’m using:

-tool - glue tool
-tool - select tool

and assing to the ‘1’ key.

now anytime you press the ‘1’ key, it will jump to an arbitrary tool (here i’m using the glue tool – no need to use ‘previous tool’), and only then go to ‘select’ tool, effectively avoiding any two subsequent 1’s that would trigger the cycling.

Brilliant.

Simple, and lets me keep the track follows event selection preference.

Thanks for taking the time to respond!