(SOLVED) Unable to download ANY in-app purchase

After downloaded Cubasis 3 (iPad) I’m unable to download ANY in-app purchase (like Halion 1.8 g Library)
The answer is “No internet connection” but it’s not true!
I’ve just downloaded Cubasis !
Other apps are connected to internet without problem.
Only in-app cubasis purchased are disconnected!
Can you fix immediately??

Hi @pierluigideioris

Thank your for your message.

If you encounter errors to download the HALion Sonic Select content, simply tap the download button again, which will resume the download in progress.

Hope that helps!


May be you don’t understand the real problem
The download NEVER start in any way.

Hi @pierluigideioris

This should normally not be the case.

Please give the following steps a try:

  • Fully shut down your iOS device.
  • Restart your router.
  • Try downloading the in-app purchases again
  • Here, give it a try downloading the smaller IAPs first (Neo FM, FM Classics)
  • HALion Sonic Select comes with a 1.8 GB content download, which can be resumed in terms of errors.

Hope that helps.

P.S.: Gave it a try to download FM Classics on the iPhone SE 2, which works as expected (see below).


Just tried !!
As some solutions found on internet the problem appear only on home connection!
I’ve FFTH fiber .
If I try with my iPhone with 4G connection all is working but with FFTH connection of my home it’s impossible to download even low size in app purchase.
Naturally ALL my other iPad app are regularly connected with internet and working.

The problem is ONLY with Cubasis

Please don’t say to restart router.
My iPad connection is ok because I just downloaded Cubasis
The problem is in-app purchase of Cubasis
Do you want a video ???

This suggests that the issue is with your FTTH ISP - there’s something wrong with the routing to the download servers that Steinberg uses (if I remember correctly, hosted on AWS).

Before latest Cubasis version all was working but now the problem is what you can see in the picture !

So must be fixed in Cubasis an not by ISP

Naturally my ISP is up and working !

That shows you have a working route to the Speedtest server. It does not prove you have a working route to the Cubasis content download servers.

I don’t know if you understand what you say ….
I’m an IT tech and this is simply ridiculous!
Now I will talk to my ISP to ask: “please give me a right route to steinberg”
Ah ah ah !!!
Do you understand what you say ?

I’m a former software engineer for a networking company.

A BGP-routed network can get into a state where traffic will flow correctly to some ASes but not to others. One example is if a BGP peer is announcing a route that its routers and firewalls will not actually permit traffic to flow over (i.e. misconfiguration), though there can be issues to do with BGP itself. As such, there is a possibility - and no more than that - that traffic to the ASes used by AWS, which is what I believe Steinberg is using for the Cubasis content download servers, is not routing correctly to and from your ISP network. The servers are self-evidently up, as you can access them via mobile data.

Wide area routing can throw up the strangest issues at times. If your ISP helpdesk is reasonably technical (as is the case for some business ISPs) then you could ask them if they are aware of any issues with traffic to and from AWS. A typical frontline tech at a consumer ISP will probably brush you off.

1 Like

A simpler scenario is that the routes within your ISP’s network for your current session have gone stale, hence @LSlowak suggesting that you reboot your router.

Done with no positive result

Can you give me AWS IP ?
In this way I can trace my route from my ISP to AWS
Never happened a thing like this

You mentioned that your iPhone connects via 4G perfectly fine, so why not making it a Hotspot, connect your iPad to the phone and try to install that way bypassing your FTTH ISP.

If that works you know where the culprit is.

That is unfortunate but it was a troubleshooting step that was in your power to resolve. If you haven’t already done so, reboot your device in case that resolves the problem.

If you are still having problems and have sufficient spare mobile data, the easy way out is to download using mobile data. If not, you could download using public Wi-Fi or try a VPN if you have a VPN service.

I’ll leave it to @LSlowak to provide any details he can of the download server. AWS is a vast global network with multiple points of presence and data centres, so proving you can send ICMP traffic to one AWS IP does not say anything useful about the ability to download (presumably using HTTPS or a similar protocol) from the specific server(s) hosting the Cubasis downloads.

1 Like

Another user with same problem that solved it only with mobile connection.
It’s a crazy solution for me and I don’t want to follow this way
I can’t post the link for the forum permission but can be found searching “fix for downloading Halion”

We can end the discussion here because it is clear that the problem cannot be solved by Steinberg
The only thing I can do is to report this problem on App Store Review

Thank you

If this comment is because I mentioned it, you are wrong. I do not have that problem.

No, it is not crazy, it is called troubleshooting in IT

Talking of troubleshooting, it would be helpful if @pierluigideioris could confirm whether his ISP and router support IPv6. It is possible that the issue is IPv6-specific and that temporarily disabling IPv6 will force a fallback to IPv4 and allow the download to succeed.

IPv4 and IPv6 routing are entirely separate.

1 Like