[SOLVED] Unable to update

I have cubasis version 2.5 installed and tried to update to 2.8…pushed the update button and after 2 seconds the update button appears again and nothing happened ?
Actual iOS and also cubasis le installed where the update has worked.
Do you have any solutions for this problem?
Thanks in advance and kind regards

Hi Alex,

Thanks for your message.

Sometimes it can take a while until updates are available and/or downloadable.

Please give it another try after some time, and let us know if it works.

If the problem persists, it might make sense to browse the web for articles about how to solve App Store issues.
There are many available containing useful tips.

Hope that helps!


Hi Lars,
Sorry for late reply…i‘been busy…
I have talked to the apple support and it seems to be a limitation of the iOS store.
Everything is fine now, I have to use the cubasis le button and this opens the cubasis app.

Kind regards

Hi Alex,

Thanks for the update.
I’m glad to hear you’ve been able to solve the issue!

Have great fun using Cubasis!