[solved] UR22 mk2 + iPhone + garageband = horrible sound


I’ve tried to connect my UR22 mk2 to my iPhone XR using an official Apple Lightning to USB adapter, the interface is detected in Garageband on iOS 13.3 but the sound I get from both inputs is absolutely horrible!

It is unusable in any way, hear for yourself (attached)
Mon morceau.zip (229 KB)

  • I’ve tried to change inputs
  • I’ve tried to change USB power supply
  • I’ve tried both mic and instruments (electric guitar)

Any idea??

I had the same problem with my unit on my laptop. I finally got it sorted with customer support today. There’s firmware on the actual UR22 mk 2 which has to be updated. One of the patches supposedly fixes that issue.

Thanks a lot for your feedback, I’ll try this as soon as possible and tell you what happened.

Yesterday I used a new Apple Lightning to USB adapter to see if it helps but it was just the same.

Solved indeed. I failed to check firmware version before… I updated to 1.04 and it works. Thanks Davie!