solved! UR824 audio output silent until switched off/on

I think I have just had a ‘eureka’ moment. I have set up a midi track directed to the Nova Midi synth, and an audio track which has input set to the Nova and output to the stereo outs 1/2. If I press the yellow monitor buttons on both tracks I now get audio output and I can record both audio and midi simultaneously. Is this the way the signal is meant to flow? I think I have misunderstood the routing - perhaps I was wrong in assuming I should get audio from my speakers by just playing on the midi track with no corresponding audio track set up? This still doesn’t explain the fact that I can get audio out by playing on the midi track alone if I reset the UR824 as I have been doing, but it would explain why setting the midi modules up as external (‘VST type’) instruments made it work as expected, as the Cubase VST instruments have always worked as I expected them to.
If anybody can confirm this is how things work then I am a happy man at last!!! When I think how I used my old Cubasis and VST 3.5 systems before, I was using an analogue mixing desk with the midi modules plugged into that, so I would have heard the audio by playing on the midi track without the need for a corresponding audio track within Cubase. Now, with everything going through the UR824, I can see I need to connect the midi module audio input to the audio outputs via an audio track to hear anything from my speakers.
Once again, I am really sorry to have wasted your time with my ignorance - I am currently chewing through an enormous slice of humble pie… :blush: :blush: :blush: :blush:

Hello Everyone
I was wondering if anybody knows what might be causing this issue. I turn on the UR824, then I start the computer (PC, Win7, I5 processor, 8GB ram, Cubase Pro 8.5 fully updated). Then start Cubase. I have 3 MIDI sound modules connected to 3 pairs of UR824 inputs. The outputs are connected to a pair of active monitors - I’m using outputs 1 and 2. If i play some notes on the master keyboard I can see audio activity on the UR824 front panel, but no sound is output. If I then switch off the UR824 and turn it on again, I then get output. I’ve only had the system set up for about a month now - everything is brand new out of the box including the PC. This issue had me scratching my head when I was setting it all up, but the on/off when Cubase is loaded seems to fix it every time - it is just an unwanted extra thing to remember to do! I was wondering if I was starting everything up in the correct order? Or if the UR824 is faulty perhaps?
If anyone has any suggestions I would be very interested to hear them…!
Many thanks

Update - pre-recorded audio files and soft synths play back when Cubase is opened, but not the audio from my MIDI modules. :frowning: Midi in/out is good. Also, the off/on trick doesn’t fix it every time. Email sent to Steinberg, hopefully have an answer soon…

So, does the Cubase output always play back, and it’s just the audio from your modules that sometimes works and sometimes doesn’t? Did you set the routing on the UR824 using the DSPFX software?


Hi Steve, thanks for your reply.
That pretty much sums it up. The audio from the modules is lighting up the lights on the UR824 when I start Cubase, suggesting the audio from the modules is getting into the interface, but I get no output from the modules until I do the off/on. I have set up all the inputs/outputs within Cubase, as the DSPFX will only start if Cubase is not turned on - I was under the impression that the DSPFX was only for non-Cubase users. If you say different I’ll take another look at that, but as everything works as expected when I do the off/on I think I’ve got the routing about right.
I had Eric from Steinberg email me yesterday with some suggestions which I’m going to try tonight - I’ll update here later either way.
Appreciate the input - have a great day.

Good luck John with the suggestions you’ve had. I really like the UR824 but I think Steinberg have been very poor with their manual and guidance about it. It would be good if they did some ‘tips and tricks’ videos or articles. For me to use both of my UR824s, I had to first set the routing options using DSPFX, save, then start again with Cubase. Having said that, your intermittent problem sounds more complex. Hope you get it working soon.


Evening all
Just a quick update - I’ve sent screenshots of all my settings to Eric @ Steinberg this evening. The previous suggestions involved renaming the cubase log file and restarting to let Cubase build a new one, but no difference unfortunately…
This is annoying, but as I can get everything working with the off/on workaround it’s still useable - just not the sort of issue I thought I’d have with new and expensive soft/hardware… :unamused:
I’m sure it will come to the good eventually…

Hello all
I have now had the UR824 returned to be repaired, had it back, no difference whatsoever, despite Eric and myself being convinced it was faulty. (I’m not sure exactly what they did to ‘fix’ it - no report or any other documentation came back with it). I’m now going to try to talk to Steinberg technical on the phone (requiring time off work… :imp: ) to see if they can fix it somehow. I have been fiddling with it in the meantime and have made an interesting discovery. I have set all my MIDI modules up as ‘external instruments’ so they will appear when you create an ‘instrument’ track. If I create a ‘vanilla’ project and then create an instrument track using one of the MIDI modules, this makes the audio play back as expected. If I then create a MIDI track for the same MIDI module it also plays back properly. However, if I start by creating a MIDI track first, I still get no output, but if I then create an instrument track for the same module, both play back properly. Screwy eh?? :cry:

I have also had the issue that some others are having re the ‘Audio Hardware Setup’ menu item disappearing. I reinstalled the UR824 software and it reappeared, and, as somebody suggested, I have not ticked the ‘do not show this message again’ box when starting Cubase and the dialogue box appears asking what ASIO driver you want to use. This seems to have stopped it disappearing at the moment… :unamused:

I had a 2 week wait for the UR824 to come back so I fired up my old computer with Cubasis and my old Terratec producer soundcard. Straight back into actually making some music, rather than fiddling around chasing my tail. I’m starting to regret the ‘upgrade’ path I’ve taken - I’m just glad that I do it as a hobby, not a job… :unamused: