[Solved]VST Connect Pro Crashes upon Insert

Hello. Ok, so, i’m a little weird-ed out about the Connect Pro. There is no installation guide, no template like there is for the Connect SE, and no easy place to find the manual. In fact the installation doesn’t even document where it is being installed, so I cannot find the pdf of the manual there either.

Now, that being stated, every time I insert the plugin on the insert of my stereo in, I get a big old “A serious problem has occurred” statement. Happily the dump is encrypted (really!!?!) so I’ve no idea what the dump is telling me.

I did finally get an error that says “Your graphics hardware or driver are outdated, graphics and video features will be limited.”. I updated my graphics driver and what not, but of course that didn’t help.

Running Windows 7, have the most recent version of Cubase (7.06). I was running a logitec video camera, but pulled it out. I am running a UR824 sound card. Anything else? I guess I should ask for my $$ back?



You’ll find the manuals in the 32 or 64 bit plug-in installation folder:
C:\Program Files (x86)\Common Files\VST3\Steinberg\VST Connect Pro
C:\Program Files\Common Files\VST3\Steinberg\VST Connect Pro

The files are called “VST_Connect_PRO_Manual.pdf” and “VST_Connect_CUE_Manual.pdf”.

Oh, sorry. Let’s try to get it up and running. The application “VST Connect Performer” is also installed on your machine. Can you start the program? Is it running?
The program is located at
C:\Program Files (x86)\Steinberg\VST Connect Performer\VST Connect Performer.exe


It was originally on the machine. It does run by itself. I removed it in case it was causing issues but got the same error.


So, as an update. Once I started using the manual to set it up, I didn’t get any errors. I think VST Connect SE doesn’t fully release the ports of communication. I originally was opening that template in Cubase 7 and then removing the SE version and attempting to insert the Pro version. W/o having the step by step in the manual it was difficult to figure out how to set it up.

It seems to be working when i just start it from scratch.

Thanks for showing me the location!!


update, it appears to be an issue w/ the camera. I keep my camera off most of the time, so while I was working w/ it to read up on it, I had the logitec c920 unplugged. When i turned it on, started up cubase, and then tried to open the template file i made it opened up. It wasn’t until I tried to open the vst connect pro on the insert channel that the whole thing crashed just like before.

could can please re-install the “VST Connect Performer”, plug your web-camera and start the program. It will Crash, right? Can you send me a private message with the Crash drump?

Thank you,

actually the connect performer boots up w/o an issue. Dump is on its way.

… did you received my private message?


Yes. Thanks. Sent you several of the dumps. Let me know if you don’t get it.