Solved: Wood Block no longer working correctly

Not sure if this is related to 2.2, but I can no longer add a Wood Block correctly.

I used to add a wood block to the bottom of the score to create a click for the demo recording I gave to my players. I can add the wood block, but it plays back as a high-pitched squeal. All other instruments are fine. (NotePerformer)

I tried opening an old project with an existing wood block track - it plays fine. But when I deleted it and added it again, same thing: high-pitched squeal on playback.

UPDATE: I solved it… somehow. I switched playback template to Silence and back to NotePerformer. Not sure why that fixed it, but it did. I didn’t think I’d need to clear it, since all other instruments were working correctly.

We ran into a problem just before version 2.2 was locked down concerning notes on percussion staves playing back incorrectly depending on the MIDI note name used to input them. Although we were able to put a fix in place, we will make some more changes in this area in future. For the time being I would recommend using the key Y to input notes onto percussion instruments rather than typing another note name, just in case our fix isn’t completely bullet-proof.


Just kidding. Got it. “Y” is a new one for me. Thanks!

It’s been there since unpitched percussion I think :wink: