Some deep troubleshooting info -- my experience

Hey all, i have been lurking these threads for a while, and after some deep troubleshooting (damn near killed my OS install, but recovered) due to issues with Latency/Dropouts/ASIO Peaking in Cubase 12. I have stumbled accross some tips that may help you resolve issues you may be having.

For the record i am running Windows 10 x64 on my Alienware Laptop
16gb Ram
i7-10750H CPU @ 2.60GHz
48Khz @ 192 Buffer on a Focusrite Scarlett 2i2 3rd Gen
(Also shot this out with a Presonus I/O24C for diagnostic purposes. Both reported the same 25% better performance in C12 over C11).

-6 Second Pre Record Time and ASIO Guard running on Medium.
-All Kontakt Instruments have ASIO Guard DISABLED via Plugin Manager.
-All kontakt Instruments also have Multiple Core Support Disabled.
-Disabled Hyperthreading in BIOS.
-Disabled SpeedStep (SpeedShift Enabled still).
-Moved from NVIDIA Studio Drivers back to GameReady Drivers.
-Modified the Task Scheduler for Windows 10 Defender to run once a month only. (Id rather not hand out step by steps, these are tips not guarentees, i dont want to be responsible for any mishap i am sorry).
-Any redundant Audio Device Drivers you have in Device Manager, Uninstall these. I had some leftover from my GoXLR device (StreamStreamingMicrophone and StreamStreamingSpeakers) which I disabled and I beleive these were the culrpits, after investigating, the unsigned drivers were causing Major CPU Interupts.

I hope some of this info helps you resolve any issues you may be having :slight_smile: II feel your pain, Cubase is a bastard at the best of times!!!

Which one of these really fixed your problems?
Reason I’m asking is that I cannot imagine that all these steps were necessary in combination to fix the issues, and I would advise for other people to not follow these tips blindly, as every system is different, but to only change one parameter at a time and then test whether that really solves your problems.

1 Like

I don’t have any issues with my projects on Windows either, and

  • I never changed a parameter for Kontakt (be it Asio Guard or “Multicore support”)
  • Still have NVidia drivers (GT 1030)
  • 2 seconds Pre Record Time and ASIO Guard on MAX
  • Hyperthreading is still active (which gives your performance a good boost if you have a multicore CPU and is recommended as well)


  • I also disabled Speedstep (that made a difference in performance, is also recommended for DAW PCs anyway)
  • Deleted all unused audio drivers (did not make any difference here, but might be a possible cause for problems)
  • Disabled Windows defender entirely (that made a difference, when opening projects)
1 Like

As i stated they are tips not a guide. I think it was the audio drivers disabled that was causing the interupts. Which was causing asio guard to peak constantly at almost timed intervals. Causing Dropouts.

You don’t need to disable it entirely for that purpose, do you? You can set exclude path and process in the Virus & threat protection settings → Exclusions and the result should be still the same?

Unfortunately its not completely the same. When opening projects, yes. But windows defender is always running in the background, using system resources. I dont need any AV running in the background at all, so I disabled it.

Hi @Tj99 ,

I’ve looked at shutting down Windows Defender for Cubase, but found there wasn’t an on/off toggle i could find, but rather a bunch of nested windows each of which needed to be shut off/disabled.

Did you have the same experienc

Yep, I disabled it throught he registry!


Why not just add exceptions?

1 Like

I would do that but I’m never sure exactly what to “except” (just a Cubase .dll file? … some other Cubase-related file? … do i need to worry about VSTi’s and plugins? … etc.), and in which of the multiple Defender dialogues.

Then there’s wondering how sticky that process would be with the numerous W10 updates.

Not to say I’m happy with what I’m doing now though, which is going through all the Defender dialogues and clicking them “off” one by one, there are a lot and I’m always worried I didn’t do it right and Defender is going to check in at just the wrong wrong time and mess up the perfect take and then Adele will give me that look again, I just hate when that happens.

If you use the system the way it’s designed it works well. Read about Windows Defender and learn how to use it to create exceptions for directories you know are safe. The amount of tinkering you’re talking about is much harder.

1 Like

It only kicks in when the OS read/write new files to the disk. If that’s for recording takes, it won’t interfere during the recording, it only checks when the file is made. Besides, you can temporarily turn off the real-time scanning just by the flick of a switch in Virus & threat protection settings → Manage settings → Real-time protection.
All in all, usually the process doesn’t have too much impact on audio performances, unlike other virus protection software. I bet your problem lies elsewhere.

1 Like

Hi @TakashiWatanabe ,
I’m actually doing OK, no interrupts, though I do get anxious about that. I use Malwarebytes and that one is easy to turn off with one click. No other virus protection type stuff here.