Some drum accents (in duplets) not functioning

In the 2-bar example below, one can see a display of many accents over the tuplets. (File included below).

Looking closely at the 2nd bar, note-head accents can be inputted everywhere EXCEPT when the ride and snare play simultaneously (bug?).

In the 1st bar, the same observation occurs. However, where the accents are flipped above the stems, the situation worsens, as now the ride and bass drum (simultanous) cannot input an accent. Essentially, the Articulations tab in the bottom window disappears.

Accents example.dorico (842.0 KB)

Dorico’s behaviour in this kind of situation is certainly not yet ideal, I will admit. However, you can get a more helpful result than you are getting at the moment with a couple of changes in approach: I would recommend not using the two options on the Percussion page of Notation Options to automatically truncate to the shortest note value or notate everything in a single voice, because this can hide what’s really going on. (In an ideal world, Dorico would be clever enough that you wouldn’t need to understand what’s really going on, but sadly it’s not quite there yet in this specific situation.)

So I would recommend switching those options off, and in the Edit Percussion Kit dialog, set all of the instruments to be in the first down-stem voice, so that everything will naturally and actually be notated in a single voice.

If you then clear out these bars and input the music again, using triplet eighths, you should find that you can create accents at every position.

The reason it isn’t working as you expect at the moment is because the ride cymbal and snare notes have different durations and are in different voices. If you ensure they are in the same voice, you should be able to add the accent with no problems.

Sorry for the hassle!