Some (heavy) libraries make Kontakt peak the CPU when playing notes if track is selected

The topic title is the summary of the problem. So whenever I load a project that has something like 8dio intimate studio strings or output substance, though the project generally plays at 20/30% CPU usage, whenever I select the kontakt track with the strings I see CPU peaks whenever a note is played in the track (or I play myself). It doesn’t happen in Kontakt’s factory library.

I’ve got windows 10, latest version of cubase 12 and kontakt 7. And the libraries run off a Seagate blue m.2 drive.

Does anyone have an idea why selecting a kontakt instrument track causes this particular peaking problem ?


If you select the track, the Record is Enabled automatically, so it turns to the real-time mode (because it expects live input). No ASIO-Guard is involved anymore. Therefore it needs more CPU and ASIO power.

You can disable the auto Record Enable in the Preferences > Editing > Project & MixConsole > Enable Record on Selected MIDI Track.

Thx, if that’s the issue than I don’t really have to worry about some anomaly right ? So I can just either configure what you proposed or when I’m playing back make sure that no track is selected and everything will be fine ? I guess having buffering set to 64 just has a knock on effect too. And having a tempo change also causes it.



The track can me selected, just disable the Record at all tracks.