Some issues and corrections

I’ve encountered some issues and discrepancies in my initial explorations of Dorico. I’ve captured some gifs and screenshots of most of them. The forum won’t let me add more than three files per post, so I’ll add the rest below. I hope it won’t be considered spamming. Apologies if any of these have already been reported. I did a quick scan of the forum and found one that I removed, but things are moving so fast here that I might have missed some.

I’m on Windows 10 Professional.

The mixer button in the toolbar doesn’t change state when I close the mixer window with the ‘X’ button in its title bar.
When I use the “e” button i Play mode to open a VST Instrument’s window, it displays, but doesn’t gain focus.
When I close a VST Instrument window with title bar ‘X’, Dorico doesn’t regain focus, even if it was the last application to have had it.

When I close a VST Instrument window with the “e” button and no application other than Dorico has had focus since opening the instrument window, when I re-open the instrument window, it appears behind Dorico, and neither Dorico nor the instrument window has focus. If I give focus to the instrument window, it is not brought to the front, and I can drag it behind Dorico. If I close the instrument window in this state using the ‘X’ in the title bar, focus is given to the last application other than Dorico to have had focus (e.g., Chrome, File Explorer, etc.), even if Dorico was the last application to have focus. I can sort of remedy this by, immediately after opening the instrument window, giving focus first to Dorico and then to the instrument window, or by clicking the instrument window’s icon in the task bar. Also, if I close the instrument window in “normal” state with title bar ‘X’, it behaves as expected when I open it again (though with the caveat of pts. 2 and 3 above).

When I close a VST Instrument window with the “e” button and an application other than Dorico has had focus since opening the instrument window, now when I re-open the instrument window with the “e” button, it doesn’t appear at all, though I can still use the task bar icon to bring it to the front.
(4 and 5 are most problematic when working in full screen mode. If not, they can be worked around as indicated)

Changing an existing dynamic doesn’t change its playback. I.e., change a ff to pp and it still plays back as ff. This applies both when using the dynamics panel and when using shift-D.

If I enter a discrete dynamic on a note that has a gradual dynamic leading up to it, the discrete dynamic doesn’t play back.

Gradual dynamics lead up to the first note or rest after the selected end note instead of up to the selected end note itself. Is this intentional? I could understand if it were, since it would be consistent with entering a gradual dynamic on a single note, even if it’s not entirely intuitive. Just wondering.

If I use shift-D to enter a combination of gradual and discrete dynamics ending with a discrete dynamic (e.g., ‘<f’) over a selection, the discrete dynamic is attached to the note or rest after the last note in the selection. I can’t make sense of this. If this element is a rest, the discrete dynamic will display slightly before the rest, which I suppose is correct, but if I delete the gradual dynamic, the discrete dynamic will snap to the rest. In addition, if the final note of my selection is at the final (visible) rhythmical position on that staff in that flow, a quarter-rest will be added at the end of the flow (or a full bar if the meter has been set). The extra rest is only added when the sequence ends with a discrete dynamic; if it ends with a gradual dynamic, no rest is created, but the dynamic does lead up to the final barline.
Octave transposing instruments in HSO are mapped inconsistently (in the VST Instrument patches themselves, that is). E.g., string bass is mapped at sounding pitch, xylophone at written pitch, and glockenspiel is wrong whichever way you look at it, as its lowest note is mapped to G above middle C, which is an octave above written and an octave below sounding. Not strictly a Dorico issue, but it does affect default playback, and I can’t find a way to change the playback transposition in Dorico.

Some Dorico instruments, such as saxophones, don’t seem to map to HALion Sonic instruments at all, though slots are reserved for them.

Dorico’s Play mode uses notation nomenclature for octaves (middle C is C4), but VST Instruments use MIDI nomenclature (middle C is C3). I’m not sure there’s a sensible resolution to this, but it is a little confusing.

In Notation Options->Accidentals->Altered unisons->Chords with multiple altered unisons, the illustration for the “Allocate only to the left” option seems to show allocation to the right. Or am I just being thick?
In Layout Options->Vertical Spacing->Minimum Gaps, the illustrations are of rather low quality compared to those in other option pages. Also, intentional or not, the “affected space” indicators on the Vertical Spacing page are not in the same style as the “Engraving Options” pages.
In Engraving Options->Accidentals->Stacking->Widely Spaced Chords->Advanced Options, the blue box states that “fixed” is default, but the actual default selection is “accurate”.

In Engraving Options->Beams->Slants->Normal Spacing->Advanced Options, the blue boxes have been switched around.

In Engraving Options->Notes->Rhythm Dots, the illustrations for “Allowed only for unisons” and “Disallowed” have been switched around.
In Engraving Options->Notes->Voices, the illustration for “Additional gap between noteheads for split stem altered unisons” does not show a split stem altered unison.

In Engraving Options->Octave Lines->Design->Continuation, the option for ottava alta label also affects the display of ottava bassa continuation. Also, the illustrations for the “include bassa” options in the bassa label/suffix section don’t actually include bassa.
In Engraving Options->Slurs->Avoiding Collisions->Cross-staff Slurs, the options and illustrations are confusing. One says “Avoid collisions” while showing a collision with the clef, the other says “Do not allow collisions” while showing collsions with pretty much everything. Should the second option be labeled “Allow collisions”?

In Engraving Options->Ties->Avoiding Collisions->Ties crossing staff lines->Advanced Options, the blue boxes are identical to the one under Positioning of ties relative to dotted notes->Advanced Options.

Absolutely don’t mean to bump this, it just occurred to me that I might not have presented things in the most digestible of fashions. Would it be better if I split the issues into separate topics? I didn’t want to do that without asking first.

I’ll go through it in detail as soon as I can. When you put 21 issues in a single thread, you have to expect that it’s not going to be the first one I decide to look at, as I need to set aside time to work through 21 issues in one sitting. Please don’t repost: I will come to it as soon as I can.

Well, Øyvind, lucky me has left your list of 21 complaints to be my last bit of forum stuff for the evening, at nearly 1.30am…

  1. The Mixer, Transport, and VST instrument buttons can get out of step with the visibility of those windows. This will be fixed in due course.

  2. The VST plug-in windows are shown by the separate VST audio engine process. There’s no keyboard interaction with them anyway, so it’s better for the focus to remain with Dorico’s window.

3, 4, 5. Unfortunately these are other side-effects of the fact that the VST audio engine is a separate process: you’re not closing a window within Dorico, but rather a window owned by another process that does not itself have a parent window, so the focus basically goes missing.

  1. This problem has been fixed since the initial release and should be improved in the first update.

  2. There is a problem whereby the final dynamic following a gradual dynamic does not always play back as it should, causing a large jump in the dynamic level, or, I guess, an insufficient jump in dynamic level. This has also been improved and should be better in the first update.

  3. A gradual dynamic extends to the end of the last note that was selected when you created it.

  4. This is the expected behaviour, for better or worse. The immediate dynamic that you’re creating goes at the end of the hairpin, and the position of the end of the hairpin (which extends to the end of the final note you selected) is the start of the following beat; if the following beat doesn’t exist, Dorico creates it. Dorico positions the immediate dynamic at the end of the hairpin rather than aligned with the rest because it’s clear that the immediate dynamic represents the final dynamic at the end of the gradual change – rests don’t typically have dynamics. But if there’s no gradual dynamic, then Dorico assumes you know what you’re doing, and puts the dynamic on the rest anyway, as putting it before the rest when there’s no hairpin before it doesn’t make any more sense than putting it on the rest.

  5. Compensating for differences in octave in HSO patches is part of the work that is ongoing with beginning to support VST Expression Maps.

  6. The problem is probably actually that Dorico is trying to play notes without knowing how to make those notes respond to volume changes. Some patches in HALion Sonic SE use VST Note Expression for volume, which Dorico can’t quite make use of just yet. Again, I expect this to be addressed very soon.

  7. I’m not sure what’s to be done here. Perhaps we will add a preference so that users can tell Dorico which number octave they thing middle C is in. This isn’t a high priority, however.

  8. Yes, you might be right that this is labeled incorrectly, but I’ll need to check with the developer who implemented split stems.

  9. Thanks for reporting this. We should be able to improve the resolution of those graphics relatively easily.

  10. Thanks, the default is correct, so the note needs to be corrected.

16-21. Thanks: we’ve fixed a couple of these already, but we will take care of the others as soon as we can.

Øyvind assembled a long list of existing issues for the benefit of the Dorico team and was careful to document them thoroughly and clearly. He was also extremely polite both in the original report and his followup, which was not a demand for attention but simply asking how he could be maximally helpful. As a software developer, I would love to have bug reports like this from my consumers. I don’t think it’s quite fair to characterize his list of issues as “complaints”, or to criticize the length of it.

Daniel has been incredible in this forum over the last few days and this is in absolutely no way a criticism of him (and his long detailed response serves as a model as well). I just want to defend Øyvind’s behavior in the face of what seemed like a bit of (understandable) annoyance, and encourage other people to report bugs just as clearly and politely.

Thank you so much for taking the time to reply to everything so thoroughly. I will definitely improve the granularity of my feedback in the future to avoid this kind of situation.

I do have one follow-up:

I see that my wording on this one was unclear. Though I have experienced what you describe, I figured it was part of the general situation with playback and would be improved in due course. What I meant was that if I add, say, a saxophone player to my score, a slot is reserved in HALion Sonic, but no patch is loaded. Same thing if I start from the concert band or sax quartet templates.

I’ve just tried this here and it has loaded the sax instruments correctly. The sax sounds aren’t part of HSO - they are part of the HALion Sonic SE presets. I suspect that they may not have been installed correctly, or they haven’t picked up the licence. A few things to try:

  • Close Dorico and run the eLicense Control Center, then run the Maintenance task to update your licences, then try again in Dorico
  • If that doesn’t work then I’d suggest installing Dorico again to ensure you get the HALion content installed correctly.

Thanks, I had a feeling that was not the expected behaviour! :slight_smile: I suspect it might be related to the fact that I already had HALion Sonic SE installed as part of an old version of Cubase (6.0). It did complain about some missing drum sounds on first load as well. If that is the case, I suppose I would have to uninstall both Cubase and Dorico before reinstalling Dorico.

(I do intend to upgrade Cubase once version 9 comes along.)

That’s absolutely fair comment, dfan. Put it down to me being stupid enough to try and work through 21 individual reports of problems starting at 1.30am after working the whole day, evening, and late evening, and being a little careless with my language. It was flippant and I apologise to you, and to Øyvind.

Øyvind, thanks for taking the time to report everything you found so thoroughly. It was the end of a long day and I hope you’ll forgive me for my careless language, and that it didn’t cause you any offence.

No problem at all, Daniel. I can’t even imagine the kind of draconian pressure you’ve been under for the past few days, and I want to take the opportunity to thank you for the massive effort you’re putting in. I remember this dedication well from the Sibelius forum, and it is one of the reasons I, and I’m sure many others, have such high hopes for Dorico.

As for myself, it was after midnight before a work day, I’d been spending most of the weekend nerdily exploring Dorico and researching the issues I encountered (honestly, who in their right mind reads through all the option pages before doing anything else? Well, they were such a pleasure to peruse that I couldn’t help myself!), and I got a little impatient in the end. If I had waited overnight, I can only hope that I would have thought better of my approach before posting instead of after, as it turned out. Anyway, all smooth sailing from here on! :slight_smile: